Bug 213284 - NullPointerException in a JDK listener reacting to change in accelerator
NullPointerException in a JDK listener reacting to change in accelerator
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: JDK Problems
7.2
PC Linux
: P4 (vote)
: 7.4
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 09:01 UTC by joh.reher
Modified: 2013-07-31 10:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE Logfile (47.12 KB, text/x-log)
2012-05-31 09:01 UTC, joh.reher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description joh.reher 2012-05-31 09:01:39 UTC
Created attachment 120107 [details]
IDE Logfile

When I started Netbeans 7.2beta I got a NPE at javax.swing.InputMap.allKeys anywhere in org.openide.awt.Toolbar which says Error in AWT task and it seems to be related to any keyboardmanager stuff.
Did not occur on second start up.

For stacktrace see attachment.
Comment 1 Petr Somol 2012-05-31 11:11:18 UTC
Svato, please reassign if it is not within your scope.
Comment 2 Stanislav Aubrecht 2013-07-31 10:51:21 UTC
I've checked JDK sources and there seem to be some extra checks for null in JDK 1.7 update 15

Please reopen if reproducible with the latest update of JDK 1.7, thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo