Bug 213269 - Some Keymap Entries are Duplicates
Some Keymap Entries are Duplicates
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Key bindings
7.2
PC Windows Vista
: P3 (vote)
: 7.4
Assigned To: Svata Dedic
issues@editor
: 7.2_WAIVER_APPROVED, 7.3_WAIVER_APPROVED
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 04:54 UTC by MackSix
Modified: 2013-09-16 04:16 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Log File (52.72 KB, application/octet-stream)
2013-03-08 14:20 UTC, MackSix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MackSix 2012-05-31 04:54:23 UTC
Tools>>Options>>Keymap (NetBeans)

Debug Target - Duplicates
Run Target - Duplicates
Threads History - Duplicate
Copy listed 6 times, but 3 are duplicates.
Cut listed 6 times, but 3 are duplicates.
Paste listed 6 times, but 3 are duplicates.
Redo listed 3 times, 1 is a duplicate.
Undo listed 4 times, 2 are duplicates.
Resynchronized Eclipse Projects - Duplicates
Set Main Project - Duplicates

Product Version: NetBeans IDE Dev (Build 201205300001)
Java: 1.7.0_04; Java HotSpot(TM) Client VM 23.0-b21
System: Windows Vista version 6.0 running on x86; Cp1252; en_US (nb)
Comment 1 Jiri Prox 2012-05-31 10:13:51 UTC
reproducible
Comment 2 Svata Dedic 2012-05-31 10:54:45 UTC
Note, the mentioned shortcuts (Copy, Cut, Set as Main Project) are duplicated in 7.0 as well, the defect is quite old.

I suspect that the cause is that actions generally lack unique nonlocalizable ID, which would allow to match them in the dialog.
Comment 3 MackSix 2012-06-04 19:22:42 UTC
(In reply to comment #2)
> Note, the mentioned shortcuts (Copy, Cut, Set as Main Project) are duplicated
> in 7.0 as well, the defect is quite old.
> 
> I suspect that the cause is that actions generally lack unique nonlocalizable
> ID, which would allow to match them in the dialog.

I saw those dupes in 7.0.1 and 7.2.1 on my system, but after uninstalling them and reinstalling them the dupes are not there now.
Comment 4 Milutin Kristofic 2012-10-22 11:44:23 UTC
These are all platform actions, I am sending it for evaluation. There is a problem to identify same actions.
Comment 5 Jaroslav Tulach 2012-10-22 12:13:39 UTC
> I suspect that the cause is that actions generally lack unique
> nonlocalizable ID, which would allow to match them in the dialog.

Unique ID of an Action is composed from category and id when registered with  @ActionID annotation.

When registered in a layer, the ID is more of less the path (minus "Actions/" prefix and ".instance" suffix) under the Actions directory.

I don't think there is much else I can do for you guys. Passing back to owners of the shortcut dialog (which is Editor/Options?).
Comment 6 Milutin Kristofic 2012-10-22 15:03:47 UTC
I report bugs for:
Debug Target - Duplicates - Bug #220591
Run Target - Duplicates - Bug #220590
Threads History - Duplicate - Bug #220592
Resynchronized Eclipse Projects - Duplicates - Bug #220594
Set Main Project - Duplicates - Bug #220595
Comment 7 Svata Dedic 2012-11-06 16:32:46 UTC
Changeset: da9b40ca04d3
Author:    Svata Dedic <sdedic@netbeans.org>
Date:      2012-11-06 17:32
Message:   Added merging from different keymap managers based on ID
Comment 8 Quality Engineering 2012-11-08 02:51:04 UTC
Integrated into 'main-golden', will be available in build *201211080001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/da9b40ca04d3
User: Svata Dedic <sdedic@netbeans.org>
Log: Issue #213269 - Some Keymap Entries are Duplicates: fixed
Added merging from different keymap managers based on ID
Comment 9 MackSix 2013-02-06 02:54:55 UTC
This is still not completely fixed.

-These entries are listed 2 times:

Paste			    PASTE	
Paste (alternative shortcut) Shift+INSERT
Paste (alternative shortcut) Ctrl+V

-These entries are listed 3 times:

Navigate to Next Occurrence Alt+DOWN
Navigate to Previous Occurrence Alt+UP

- These entries are listed 2 times, once with a shortcut and once without a shortcut.

New Breakpoint 
Run to Cursor 
Step Into 
Step Out 
Step Over 

- Replace listed twice as "Replace" and "Replace..." with Ctrl+H.


Product Version: NetBeans IDE 7.3 RC1 (Build 201301240957)
Java: 1.7.0_13; Java HotSpot(TM) 64-Bit Server VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_13-b20
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 10 Svata Dedic 2013-03-08 13:32:20 UTC
Not a P2, IMHO. I wouldn't consider it a patch candidate either; the root cause is that some actions which should have been identified as one logical piece are separate in the UI.

Paste action can be fixed in Dev.

Prev/next occurrence is already reported as issue #125741 and issue #194356; we lack an API or convention for equivalent actions provided by different editor(kits).
The Step/Run actions are similar to issue #194356 -- two actions registered by two independent languages (e.g. java / C++ - that's where I found it).

MackSix@netbeans.org: could you please attach your IDE.log for the list of loaded modules ?
Comment 11 MackSix 2013-03-08 14:20:52 UTC
Created attachment 132382 [details]
Log File

Log file to who loaded modules.
Comment 12 Svata Dedic 2013-03-08 14:37:48 UTC
confirmed, cnd was present even in case of comment #9.

I'm going to fix the paste action; the rest should be handled as issue #194356;
Comment 13 Svata Dedic 2013-03-08 14:38:02 UTC
Changeset: 0288917b5fea
Author:    Svata Dedic <sdedic@netbeans.org>
Date:      2013-03-08 15:37
Message:   Updated paste action ID to value used by openide.
Comment 14 Quality Engineering 2013-03-13 02:08:33 UTC
Integrated into 'main-golden', will be available in build *201303122300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/0288917b5fea
User: Svata Dedic <sdedic@netbeans.org>
Log: Issue #213269 - Some Keymap Entries are Duplicates: fixed
Updated paste action ID to value used by openide.
Comment 15 MackSix 2013-09-16 04:16:32 UTC
These duplicates have also been fixed in 7.4 RC1:

New Breakpoint 
Run to Cursor 
Step Into 
Step Out 
Step Over 

Product Version: NetBeans IDE 7.4 RC1 (Build 201309112301)
Java: 1.7.0_40; Java HotSpot(TM) 64-Bit Server VM 24.0-b55
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b40
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo