Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 213161 - Save actions
Save actions
Status: RESOLVED DUPLICATE of bug 140719
Product: editor
Classification: Unclassified
Component: Actions/Menu/Toolbar
7.1.2
PC Windows 7
: P3 with 2 votes (vote)
: TBD
Assigned To: Miloslav Metelka
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 13:55 UTC by javydreamercsw
Modified: 2013-08-10 14:48 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2012-05-29 13:55:09 UTC
In Eclipse, you can configure different things to happen every time a file is saved, such as formatting the code, fixing imports, cleaning up white space, etc. This I have not been able to do in NetBeans.
Comment 2 markiewb 2013-08-10 14:48:39 UTC
NetBeans 7.3 introduces SaveActions. #140719

For example NB7.4 provides the following save actions for the java editor
* Reformat 
* Remove trailing whitespace
* Remove unused imports
* Organised imports

I propose to open separate issues if you like to see more.

*** This bug has been marked as a duplicate of bug 140719 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo