Bug 213007 - LowPerformance took 160074 ms.
LowPerformance took 160074 ms.
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.2
All All
: P3 (vote)
: TBD
Assigned To: Antonin Nebuzelsky
issues@platform
EXCEPTIONS_REPORT perf-profileme jdk_...
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 10:06 UTC by Petr Jiricka
Modified: 2012-05-25 12:13 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (128.50 KB, application/nps)
2012-05-25 10:06 UTC, Petr Jiricka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2012-05-25 10:06:05 UTC
This issue was reported manually by pjiricka.
It already has 1 duplicates 


Build: NetBeans IDE Dev (Build EaselCSS-187-on-20120524)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b21
OS: Mac OS X

User Comments:
pjiricka: Switched back to IDE after doing something else.



Maximum slowness yet reported was 160074 ms, average is 160074
Comment 1 Petr Jiricka 2012-05-25 10:06:14 UTC
Created attachment 119873 [details]
nps snapshot
Comment 2 Petr Jiricka 2012-05-25 10:10:10 UTC
Originally this was a duplicate of bug 176458, which is filed against JIndent plugin, but I don't have this plugin, so it's a different issue. 

Looking at the snapshot this looks like a JDK problem - 160s is spent in a native Mac OS X method, which is called from Swing code in AWT thread.
Comment 3 Antonin Nebuzelsky 2012-05-25 12:13:54 UTC
JDK bug #7171787.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo