Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 212995 - Inspect and transform error list is not "linked" to files
Inspect and transform error list is not "linked" to files
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Refactoring
7.2
PC Linux
: P3 (vote)
: TBD
Assigned To: Ralph Ruijs
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 08:52 UTC by pcornelissen
Modified: 2016-07-07 07:31 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pcornelissen 2012-05-25 08:52:12 UTC
When using the inspect and transform refactoring, you may get a list of errors.
In my case "Access of Private Field of Another Object at ..."

The problem is that the list is not linked to the corresponding source files+lines, which would make it much easier to fix the defect that prevents the inspect and transform  refactoring to work...

It it possible to add some kind of jump to file context menu or simply a link on the item or file name?
Comment 1 Petr Somol 2012-05-25 10:55:19 UTC
Actually I tried Inspect and Transform and in was possible to jump to the source line by double-clicking the hint. Jan, would you please confirm that this functionality is already implemented in full ?
Comment 2 pcornelissen 2012-05-25 11:06:43 UTC
I just rechecked and double clicked on the icon, the line and in free space of the lines. Nothing had an effect. It's just a text line. By clicking the text or parts of it are selected. Looks more like a Multiline text view with alternating row colors than a listview ;-)

I'm using the 7.2 Beta build from the website, that I downloaded yesterday.

Product Version: NetBeans IDE 7.2 Beta (Build 201205031832)
Java: 1.7.0_03; OpenJDK 64-Bit Server VM 22.0-b10
System: Linux version 3.2.0-2-amd64 running on amd64; UTF-8; de_DE (nb)
Comment 3 Jan Lahoda 2012-05-25 20:27:44 UTC
Petr, I believe that the reporter meant the problems listed in the refactoring dialog, not the result window.

In most cases, it was a bug to show these as the problems instead of showing them in the results window (because these are not real problems with processing, but rather incorrectly shown processing results). That has been fixed recently (post 7.2 beta), as part of:
http://hg.netbeans.org/main-silver/rev/3f658c169d32

There are a few places were actual problems are reported through the same interface, and I agree it might be useful to allow the user browse through them in a more convenient way. Not strictly related to I&T, as other refactorings use the same channels to show processing problems. As such, some support in the refactoring APIs is needed.

For the record, it is not certain if these "query-only" hints will be available in I&T in the future - the Source/Inspect... should provide a better UI to handle them.
Comment 4 Martin Balin 2016-07-07 07:31:06 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo