Bug 212935 - Deadlock during project opening (o.n.m.j2ee.deployment.impl.ServerRegistry waits for lock held by AbstractLogicalViewProvider.RP)
Deadlock during project opening (o.n.m.j2ee.deployment.impl.ServerRegistry wa...
Status: RESOLVED DUPLICATE of bug 205319
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.1
PC Mac OS X
: P1 (vote)
: TBD
Assigned To: Vince Kraemer
issues@serverplugins
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-24 09:02 UTC by Tomas Danek
Modified: 2012-05-24 09:17 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2012-05-24 09:02:13 UTC
extracted from issue 212590. Not a first time this happened according to comments.

User config: Product Version: NetBeans IDE 7.1.2 (Build 201204101705)
Java: 1.7.0_04; Java HotSpot(TM) 64-Bit Server VM 23.0-b21
System: Mac OS X version 10.7.4 running on x86_64; UTF-8; en_US (nb)
User directory: /Users/garbi/.netbeans/7.1.2
Cache directory: /Users/garbi/.netbeans/7.1.2/var/cache


"Thread-9":
	at org.netbeans.modules.j2ee.deployment.impl.ServerRegistry.getServerInstance(ServerRegistry.java:318)
	- waiting to lock <0x00000007d1b05578> (a org.netbeans.modules.j2ee.deployment.impl.ServerRegistry)
	at org.netbeans.modules.j2ee.deployment.plugins.api.InstanceProperties.getInstanceProperties(InstanceProperties.java:155)
	at org.netbeans.modules.glassfish.javaee.Hk2DeploymentManager.getInstanceProperties(Hk2DeploymentManager.java:589)
	at org.netbeans.modules.glassfish.javaee.Hk2StartServer.<init>(Hk2StartServer.java:103)
	at org.netbeans.modules.glassfish.javaee.Hk2OptionalFactory.getStartServer(Hk2OptionalFactory.java:110)
	at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.getStartServer(ServerInstance.java:612)
	- locked <0x00000007d1b98b48> (a org.netbeans.modules.j2ee.deployment.impl.ServerInstance)
	at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.isRunningWithinMillis(ServerInstance.java:904)
	at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.isRunning(ServerInstance.java:897)
	at org.netbeans.modules.j2ee.deployment.impl.TargetServer.notifyArtifactsUpdated(TargetServer.java:813)
	at org.netbeans.modules.j2ee.deployment.impl.DeployOnSaveManager$DeployTask.notifyServer(DeployOnSaveManager.java:497)
	at org.netbeans.modules.j2ee.deployment.impl.DeployOnSaveManager$DeployTask.run(DeployOnSaveManager.java:414)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:722)
"AbstractLogicalViewProvider.RP":
	at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.getDisconnectedDeploymentManager(ServerInstance.java:306)
	- waiting to lock <0x00000007d1b98b48> (a org.netbeans.modules.j2ee.deployment.impl.ServerInstance)
	at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.getDisconnectedServerLibraryManager(ServerInstance.java:718)
	at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.isServerLibraryManagementSupported(ServerInstance.java:762)
	at org.netbeans.modules.j2ee.deployment.devmodules.api.ServerInstance.getLibraryManager(ServerInstance.java:218)
	- locked <0x00000007d1b05578> (a org.netbeans.modules.j2ee.deployment.impl.ServerRegistry)
	at org.netbeans.modules.j2ee.common.ui.BrokenServerLibrarySupport.getMissingServerLibraries(BrokenServerLibrarySupport.java:159)
	at org.netbeans.modules.j2ee.common.ui.BrokenServerLibrarySupport.isBroken(BrokenServerLibrarySupport.java:95)
	at org.netbeans.modules.j2ee.common.project.ui.AbstractLogicalViewProvider.hasBrokenServerLibrary(AbstractLogicalViewProvider.java:916)
	at org.netbeans.modules.j2ee.common.project.ui.AbstractLogicalViewProvider.access$1600(AbstractLogicalViewProvider.java:125)
	at org.netbeans.modules.j2ee.common.project.ui.AbstractLogicalViewProvider$5.run(AbstractLogicalViewProvider.java:424)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1411)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1991)


Full threaddump available here: http://netbeans.org/bugzilla/attachment.cgi?id=119800
Comment 1 Jiri Skrivanek 2012-05-24 09:17:19 UTC
Should be already fixed in 7.2 dev builds.

*** This bug has been marked as a duplicate of bug 205319 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo