Bug 212918 - NullPointerException at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.getExistingFor
NullPointerException at org.netbeans.modules.masterfs.filebasedfs.fileobjects...
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Filesystems
7.2
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 23:14 UTC by Jesse Glick
Modified: 2012-05-24 11:57 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.68 KB, text/plain)
2012-05-23 23:14 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-05-23 23:14:18 UTC
This bug was originally marked as duplicate of bug 209466, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 20120523-d94032db4da4)
VM: Java HotSpot(TM) Client VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b22
OS: Windows XP

User Comments:
jglick: Project open on UNC path. Possibly fixed by #207060 but should probably be made robust at this point anyway.




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.getExistingFor(BaseFileObj.java:1025)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.getExistingParentFor(BaseFileObj.java:1031)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.BaseFileObj.getExistingParent(BaseFileObj.java:1035)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.RefreshSlow.progress(RefreshSlow.java:103)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.RefreshSlow.refreshFileObject(RefreshSlow.java:93)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.refresh(FileObjectFactory.java:533)
Comment 1 Jesse Glick 2012-05-23 23:14:26 UTC
Created attachment 119786 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-05-24 06:05:50 UTC
Possibly fixed by 9ecf36d8c800, but I have added more verbose error message anyway: b162cada275a - will print out the name of the file now
Comment 3 Jesse Glick 2012-05-24 11:57:27 UTC
(In reply to comment #2)
> Possibly fixed by 9ecf36d8c800

Possibly - but this was pushed eight days ago and is still not in main-silver. Why?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo