Bug 212897 - externally changed files from a symlinked folder aren't refreshed
externally changed files from a symlinked folder aren't refreshed
Status: RESOLVED DUPLICATE of bug 225558
Product: platform
Classification: Unclassified
Component: Filesystems
7.2
PC Mac OS X
: P4 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-23 13:16 UTC by Tomas Stupka
Modified: 2013-09-04 13:54 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Stupka 2012-05-23 13:16:26 UTC
Product Version = NetBeans IDE Dev (Build 20120522-968b3ca196a2) (#968b3ca196a2)
Operating System = Mac OS X version 10.6.8 running on x86_64
Java; VM; Vendor = 1.6.0_31; Java HotSpot(TM) 64-Bit Server VM 20.6-b01-415; Apple Inc.
Runtime = Java(TM) SE Runtime Environment 1.6.0_31-b04-415-10M3646

have a file in the IDE which comes from a symlink folder

externally change the file => the file is notified by its real path to the watcher, but the watcher doesn't propagate the event because there is no FO instance (only the symlink instance exists)
Comment 1 Jaroslav Tulach 2012-11-09 17:12:00 UTC
Let's pretend this is not the common case (althrough in case of PHP one cannot be really sure) and lower the priority.

Anyway the only way to do something with this is to have the symlink detection inside the masterfs. Tomáš already has one issue that would need the symlink detection to be moved from parsing.api to masterfs, so adding him to CC.
Comment 2 Jaroslav Havlin 2013-09-04 13:54:27 UTC

*** This bug has been marked as a duplicate of bug 225558 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo