Bug 212812 - 99% CPU Use at Startup
99% CPU Use at Startup
Status: RESOLVED DUPLICATE of bug 212620
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
7.2
PC Windows XP
: P2 (vote)
: 7.2
Assigned To: Tomas Zezula
issues@editor
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-22 07:42 UTC by bht
Modified: 2012-05-23 12:12 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Snapshot and logs in zip file (121.47 KB, application/x-zip)
2012-05-22 07:42 UTC, bht
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bht 2012-05-22 07:42:41 UTC
Created attachment 119712 [details]
Snapshot and logs in zip file

CPU is at 99%
Background scanning of projects is at 85% and stays there. I click the button "Profile the IDE" and after a minute I click it again. Loading the snapshot takes very long. But after saving the snapsot, the IDE finally recovers which is different from the other bug that I reported.
Comment 1 Marian Mirilovic 2012-05-23 09:24:11 UTC
reassign to perf. team for further evaluation
Comment 2 Petr Cyhelsky 2012-05-23 11:42:05 UTC
Most of the time is spent in parsing and indexing.
Tomasi please take a look - note that there are many exceptions in messages.log similar to:

java.lang.AssertionError: Need to normalize C:\DOCUME~1\name\LOCALS~1\Temp\db4fb0351683fb208a9c84f0e12b7472a2abb681.jar was C:\Documents and Settings\name\Local Settings\Temp\db4fb0351683fb208a9c84f0e12b7472a2abb681.jar
	at org.openide.filesystems.FileUtil.assertNormalized(FileUtil.java:141)
	at org.openide.filesystems.FileUtil.addFileChangeListener(FileUtil.java:282)
	at org.netbeans.modules.java.source.parsing.CachingArchive.<init>(CachingArchive.java:96)
	at org.netbeans.modules.java.source.parsing.CachingArchiveProvider.create(CachingArchiveProvider.java:170)
	at org.netbeans.modules.java.source.parsing.CachingArchiveProvider.getArchive(CachingArchiveProvider.java:97)
	at org.netbeans.modules.java.source.parsing.CachingFileManager.list(CachingFileManager.java:128)
	at org.netbeans.modules.java.source.parsing.ProxyFileManager.list(ProxyFileManager.java:192)
	at com.sun.tools.javac.jvm.ClassReader.fillIn(ClassReader.java:2552)
	at com.sun.tools.javac.jvm.ClassReader.complete(ClassReader.java:2225)
	at com.sun.tools.javac.code.Symbol.complete(Symbol.java:422)
	at com.sun.tools.javac.comp.Enter.visitTopLevel(Enter.java:339)
	at com.sun.tools.javac.tree.JCTree$JCCompilationUnit.accept(JCTree.java:457)
	at com.sun.tools.javac.comp.Enter.classEnter(Enter.java:298)
	at com.sun.tools.javac.comp.Enter.classEnter(Enter.java:312)
	at com.sun.tools.javac.comp.Enter.complete(Enter.java:704)
	at com.sun.tools.javac.main.JavaCompiler.complete(JavaCompiler.java:983)
	at com.sun.tools.javac.main.JavaCompiler.enterTrees(JavaCompiler.java:949)
	at com.sun.tools.javac.api.JavacTaskImpl.enter(JavacTaskImpl.java:369)
	at com.sun.tools.javac.api.JavacTaskImpl.enterTrees(JavacTaskImpl.java:417)
[catch] at org.netbeans.modules.java.source.indexing.MultiPassCompileWorker.compile(MultiPassCompileWorker.java:203)
	at org.netbeans.modules.java.source.indexing.JavaCustomIndexer.index(JavaCustomIndexer.java:229)
	at org.netbeans.modules.parsing.spi.indexing.Indexable$MyAccessor$2.run(Indexable.java:158)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater.runIndexer(RepositoryUpdater.java:259)
	at org.netbeans.modules.parsing.spi.indexing.Indexable$MyAccessor.index(Indexable.java:156)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doIndex(RepositoryUpdater.java:2445)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.access$1500(RepositoryUpdater.java:2045)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work$2.run(RepositoryUpdater.java:2352)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work$2.run(RepositoryUpdater.java:2350)
	at org.netbeans.modules.parsing.impl.indexing.errors.TaskCache.refreshTransaction(TaskCache.java:541)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.index(RepositoryUpdater.java:2350)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$AbstractRootsWork.scanSource(RepositoryUpdater.java:4763)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$AbstractRootsWork.scanSources(RepositoryUpdater.java:4489)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$RootsWork.getDone(RepositoryUpdater.java:4202)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:2940)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task._run(RepositoryUpdater.java:5176)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.access$4800(RepositoryUpdater.java:4868)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2$1.run(RepositoryUpdater.java:5113)
	at org.netbeans.modules.parsing.impl.RunWhenScanFinishedSupport.performScan(RunWhenScanFinishedSupport.java:97)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2.call(RepositoryUpdater.java:5109)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task$2.call(RepositoryUpdater.java:5105)
	at org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO(FileChangedManager.java:176)
	at org.netbeans.modules.masterfs.providers.ProvidedExtensions.priorityIO(ProvidedExtensions.java:360)
	at org.netbeans.modules.parsing.impl.Utilities.runPriorityIO(Utilities.java:72)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.run(RepositoryUpdater.java:5105)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032)
Comment 3 Jan Lahoda 2012-05-23 11:44:07 UTC
Sounds like a duplicate of bug #212620.
Comment 4 Tomas Zezula 2012-05-23 12:12:05 UTC

*** This bug has been marked as a duplicate of bug 212620 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo