Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 212622 - Distinguish between skipped and paseed test - make possible to filter skipped
Distinguish between skipped and paseed test - make possible to filter skipped
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: TestNG
7.2
All All
: P2 with 1 vote (vote)
: 7.4
Assigned To: Theofanis Oikonomou
issues@java
:
: 186276 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 10:11 UTC by Tomas Danek
Modified: 2013-09-04 15:01 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2012-05-17 10:11:06 UTC
Product Version: NetBeans IDE Dev (Build 201205160400)
Java: 1.7.0_04; Java HotSpot(TM) 64-Bit Server VM 23.0-b21
System: Mac OS X version 10.7.4 running on x86_64; US-ASCII; en_US (nb)
User directory: /Users/tomas/Library/Application Support/NetBeans/dev
Cache directory: /Users/tomas/Library/Caches/NetBeans/dev
------------
- current implementation counts skipped tests (skipped is test which was dependent on e.g. method that failed and therefore did not execute) as passed, which is not correct. Please make some specific category 'skipped' that is possible to filter out in test results.
Comment 1 Jesse Glick 2013-03-13 16:40:49 UTC
Applicable also to @Ignore (and AssumptionViolatedException) in JUnit 4. Ant 1.9.0 now correctly reports there, and Maven Surefire has done so for some time.
Comment 2 Theofanis Oikonomou 2013-03-15 09:59:15 UTC
Changeset: 33fec46ef04e
Author:    Theofanis Oikonomou <theofanis@netbeans.org>
Date:      2013-03-15 10:57
Message:
Comment 3 Theofanis Oikonomou 2013-03-15 10:06:53 UTC
For the TestNG case this was fixed by http://hg.netbeans.org/core-main/rev/54ab3b4342e4
Comment 4 Jesse Glick 2013-03-15 13:30:07 UTC
I guess the preceding commented-out lines

//        if(testingFramework.equals(Manager.TESTNG_TF) || testingFramework.equals(Manager.JUNIT_TF)) {
//            toolbar.add(btnShowIgnored);
//        }

is also now obsolete.
Comment 5 Quality Engineering 2013-03-16 01:50:39 UTC
Integrated into 'main-golden', will be available in build *201303152300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/33fec46ef04e
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: Issue #212622 - Distinguish between skipped and paseed test - make possible to filter skipped
Comment 6 Theofanis Oikonomou 2013-09-04 15:01:41 UTC
*** Bug 186276 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo