Bug 212478 - LowPerformance took 5051 ms.
LowPerformance took 5051 ms.
Status: RESOLVED WORKSFORME
Product: javascript
Classification: Unclassified
Component: Debugger
7.2
All All
: P3 (vote)
: 7.3
Assigned To: David Konecny
issues@javascript
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-14 13:24 UTC by Petr Jiricka
Modified: 2012-06-26 21:44 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (14.35 KB, application/nps)
2012-05-14 13:24 UTC, Petr Jiricka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2012-05-14 13:24:33 UTC
This bug was originally marked as duplicate of bug 210981, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build EaselCSS-170-on-20120514)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.0-b21, Java(TM) SE Runtime Environment, 1.7.0_04-b21
OS: Mac OS X

User Comments:
pjiricka: Opening the WebView browser for the first time.



Maximum slowness yet reported was 5051 ms, average is 5051
Comment 1 Petr Jiricka 2012-05-14 13:24:41 UTC
Created attachment 119430 [details]
nps snapshot
Comment 2 Stanislav Aubrecht 2012-05-24 13:12:59 UTC
The problem is that ...webkit.debugging.api.Debugger.enable() is waiting for something in EDT.

(not sure where to reassign, so pls feel free to pass over to somewhere else)
Comment 3 Petr Jiricka 2012-05-24 13:33:36 UTC
I think the correct place is JavaScript debugging.
Comment 4 David Konecny 2012-06-26 21:44:54 UTC
All debugging protocol calls are now run outside of AWT. This should just work now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo