Bug 21236 - Ext-Browser: Message "Could not access the URL" to guide from Tools menu
Ext-Browser: Message "Could not access the URL" to guide from Tools menu
Status: RESOLVED WORKSFORME
Product: ide
Classification: Unclassified
Component: Extbrowser
3.x
All All
: P3 (vote)
: 4.x
Assigned To: Martin Grebac
issues@ide
:
: 33962 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-06 11:56 UTC by Jan Zajicek
Modified: 2004-10-27 17:20 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Zajicek 2002-03-06 11:56:36 UTC
This issue was transfered from bugtraq:


IDE Build 020301_1 EA RC1 
When External Browser" is not configured properly, 
user gets a dialog titled "Exception" with the message
'Could not access the URL through th eexternal browser. Check the configuration.
In the Options window, expand IDE Configuration.....'

The Message guidance needs to start from the "Tools Menu Choose the Options
menuitem "..
Also, can the dialog title be chnaged from "Exception" to "Error" ?
Comment 1 _ rkubacki 2002-03-06 12:33:17 UTC
Can anyone refine the message before I will commit it?
Comment 2 Gail Chappell 2002-03-06 17:05:42 UTC
I looked at the original message in the resource bundle.  Here is
what I suggest:

Could not access the URL through the external browser. Check the 
browser configuration.  From the Tools menu, choose Options.  In
the Options window, expand the IDE Configuration node.  Then expand
the Server and External Tool Settings node followed by the Web
Browsers node. Select the external browser type and modify the Browser
Executable property if necessary.

Comment 3 _ ttran 2002-03-07 07:23:06 UTC
People, please set the component field properly.  This is not core,
but extbrowser.
Comment 4 _ rkubacki 2002-03-07 15:51:35 UTC
I applied Gail's message to NetBeans trunk.
Comment 5 Oleg Khokhlov 2002-03-25 10:13:48 UTC
Verified with nb dev build 200203250100
Comment 6 essin 2004-07-08 19:15:42 UTC
This problem is still an issue in 3.6 on some windows XP machines.

No external web browsers will launch. Not Firefox, netscape or IE.
only the internal one will work at all.

There is also a problem, perhaps related, that the path the the
default system browser in in the old dos 8.3 formate and will not
update even if you browse and locate the file. The find file dialog
shows the full, correct path name but this does not update the config
property when selected.
Comment 7 pzajac 2004-09-08 10:06:00 UTC
Please annotate the exception. On the welkome screen are some
weblinks. When the webrowser is not correctly configured the exception
is shown to user on clicking to a url. 

IHMO this issue should be solved for 4.0 release. 
Comment 8 Marian Petras 2004-10-18 09:31:30 UTC
*** Issue 33962 has been marked as a duplicate of this issue. ***
Comment 9 Martin Grebac 2004-10-27 17:20:57 UTC
I looked at this and don't understand which exception should be
annotated. Could you provide log of the exception and a reproducible
case with description?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo