Bug 212278 - ClassCastException: [Lorg.openide.nodes.Node; cannot be cast to [Lorg.netbeans.modules.csl.navigation.ElementNode;
ClassCastException: [Lorg.openide.nodes.Node; cannot be cast to [Lorg.netbean...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: CSL (API & infrastructure)
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Milutin Kristofic
issues@editor
EXCEPTIONS_REPORT
:
: 212359 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 08:27 UTC by schkovich
Modified: 2012-05-23 08:33 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.02 KB, text/plain)
2012-05-10 08:27 UTC, schkovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-05-10 08:27:33 UTC
Build: NetBeans IDE Dev (Build 201205090400)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: Navigator did not show PHP node of the abstract class to refresh it I changed sorting.




Stacktrace: 
java.lang.ClassCastException: [Lorg.openide.nodes.Node; cannot be cast to [Lorg.netbeans.modules.csl.navigation.ElementNode;
   at org.netbeans.modules.csl.navigation.ElementNode.refreshRecursively(ElementNode.java:206)
   at org.netbeans.modules.csl.navigation.ElementNode.refreshRecursively(ElementNode.java:196)
   at org.netbeans.modules.csl.navigation.ClassMemberPanelUI$7.run(ClassMemberPanelUI.java:372)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032)
Comment 1 schkovich 2012-05-10 08:27:38 UTC
Created attachment 119253 [details]
stacktrace
Comment 2 Milutin Kristofic 2012-05-10 12:05:33 UTC
Svata, would you please evaluate this. You know changes in csl.navigation
Comment 3 Svata Dedic 2012-05-10 12:28:53 UTC
Changeset: 594224ef321d
Author:    Svata Dedic <sdedic@netbeans.org>
Date:      2012-05-10 14:28
Message:   Issue #212278 - ClassCastException: [Lorg.openide.nodes.Node; cannot be cast to [Lorg.netbeans.modules.csl.navigation.ElementNode;: fixed
#212278: Incorrect typecast; the resulting collection should be casted, no the Node[]
Comment 4 Quality Engineering 2012-05-12 09:57:40 UTC
Integrated into 'main-golden', will be available in build *201205120400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/2fe6be1f3dd0
User: Svata Dedic <sdedic@netbeans.org>
Log: #212278: Fixed incorrect typecast
Comment 5 Svata Dedic 2012-05-23 08:33:35 UTC
*** Bug 212359 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo