Bug 212262 - LowPerformance took 7828 ms. RecentFileAction.getIcon() -> JaxWsDataLoader -> FileOwnerQuery -> MavenEmbedder
LowPerformance took 7828 ms. RecentFileAction.getIcon() -> JaxWsDataLoader ->...
Status: RESOLVED FIXED
Product: webservices
Classification: Unclassified
Component: JAX-WS
7.2
All All
: P3 (vote)
: 7.3
Assigned To: Denis Anisimov
issues@webservices
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
: 225635 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 20:33 UTC by Jesse Glick
Modified: 2013-04-15 15:51 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (204.51 KB, application/nps)
2012-05-09 20:33 UTC, Jesse Glick
Details
screenshot (182.50 KB, image/png)
2012-05-17 09:35 UTC, Milos Kleint
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-05-09 20:33:29 UTC
This bug was originally marked as duplicate of bug 202398, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 20120507-02f2a340f737)
VM: Java HotSpot(TM) Client VM, 20.7-b02, Java(TM) SE Runtime Environment, 1.6.0_32-b05
OS: Linux

User Comments:
jglick: File > Recent File



Maximum slowness yet reported was 7828 ms, average is 7828
Comment 1 Jesse Glick 2012-05-09 20:33:44 UTC
Created attachment 119236 [details]
nps snapshot
Comment 2 Milos Kleint 2012-05-17 09:35:42 UTC
Created attachment 119561 [details]
screenshot

recent popup menu uses icon from dataobject and jaxwsdataloader uses FileOwnerQuery to locate project. Most time then spent in maven project's embedder initialization and project loading
Comment 3 Quality Engineering 2012-06-05 06:02:29 UTC
Integrated into 'main-golden', will be available in build *201206050001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/08d1f52a77bd
User: Milos Kleint <mkleint@netbeans.org>
Log: #212262 don't construct instance of RepositoryPreference when only simple value pref is set ot retrieved
Comment 4 Milos Kleint 2012-06-05 06:05:35 UTC
jaxwsdataloader should not consider file ownership when claiming files and creating data objects..
Comment 5 Denis Anisimov 2012-09-10 17:15:34 UTC
web-main#75da9ee7919a
Comment 6 Quality Engineering 2012-09-11 02:21:11 UTC
Integrated into 'main-golden', will be available in build *201209110001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/75da9ee7919a
User: Denis Anisimov <ads@netbeans.org>
Log: Fix for BZ#180963 - Designer does not appear until the Web Services node is expanded , BZ#212262 - LowPerformance took 7828 ms. RecentFileAction.getIcon() -> JaxWsDataLoader -> FileOwnerQuery -> MavenEmbedder, BZ#217692 - Possible deadlock at CVS or background scanning
Comment 7 Sergey Petrov 2013-04-12 12:47:58 UTC
*** Bug 225635 has been marked as a duplicate of this bug. ***
Comment 8 Sergey Petrov 2013-04-15 15:51:53 UTC
*** Bug 225635 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo