Bug 212120 - Cannot merge changes from the trunk into working copy
Cannot merge changes from the trunk into working copy
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.2
PC Linux
: P3 (vote)
: 7.2
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
: 213263 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-05 09:12 UTC by schkovich
Modified: 2012-06-01 08:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-05-05 09:12:19 UTC
Working copy is pointing to the feature branch. Merge the trunk to keep the branch in sync.

Right click on the project root directory. Select Subversion > Merge Changes. On Merge Into ProjectName dialog select One Repository Folder Since Origin, browse repository and select trunk. Preview showing that trunk will into the working copy. Click merge.

Expected:
Trunk merged into the working copy.

Actual:
Dialog pops up stating: Filesystem has no item svn: '/svn/!svn/bc/0/MIS/trunk' path not found
Merge fails.
INFO [org.netbeans.modules.subversion]: org.apache.subversion.javahl.ClientException: Filesystem has no item
svn: '/svn/!svn/bc/0/MIS/trunk' path not found

org.apache.subversion.javahl.ClientException: Filesystem has no item
svn: '/svn/!svn/bc/0/MIS/trunk' path not found

	at org.apache.subversion.javahl.SVNClient.logMessages(Native Method)
	at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getLogMessages(AbstractJhlClientAdapter.java:2490)
Caused: org.tigris.subversion.svnclientadapter.SVNClientException
	at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getLogMessages(AbstractJhlClientAdapter.java:2501)
	at org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter.getLogMessages(AbstractJhlClientAdapter.java:2540)
	at org.tigris.subversion.svnclientadapter.AbstractClientAdapter.getLogMessages(AbstractClientAdapter.java:200)
	at org.tigris.subversion.svnclientadapter.AbstractClientAdapter.getLogMessages(AbstractClientAdapter.java:189)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.handle(SvnClientInvocationHandler.java:360)
	at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.invokeMethod(SvnClientInvocationHandler.java:321)
	at org.netbeans.modules.subversion.client.SvnClientInvocationHandler$2.call(SvnClientInvocationHandler.java:169)
	at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.invoke(SvnClientInvocationHandler.java:175)
	at $Proxy17.getLogMessages(Unknown Source)
[catch] at org.netbeans.modules.subversion.ui.copy.MergeAction.performMerge(MergeAction.java:200)
	at org.netbeans.modules.subversion.ui.copy.MergeAction.access$000(MergeAction.java:69)
	at org.netbeans.modules.subversion.ui.copy.MergeAction$1.perform(MergeAction.java:133)
	at org.netbeans.modules.subversion.client.SvnProgressSupport.performIntern(SvnProgressSupport.java:109)
	at org.netbeans.modules.subversion.client.SvnProgressSupport.run(SvnProgressSupport.java:102)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032)
WARNING [org.netbeans.ProxyClassLoader]: Will not load class org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter arbitrarily from one of ModuleCL@fb5265f[org.netbeans.libs.svnClientAdapter.svnkit] and ModuleCL@3dea2f07[org.netbeans.libs.svnClientAdapter.javahl] starting from SystemClassLoader[307 modules]; see http://wiki.netbeans.org/DevFaqModuleCCE
WARNING [org.netbeans.ProxyClassLoader]: Will not load class org.apache.subversion.javahl.SVNClient arbitrarily from one of ModuleCL@fb5265f[org.netbeans.libs.svnClientAdapter.svnkit] and ModuleCL@3dea2f07[org.netbeans.libs.svnClientAdapter.javahl] starting from SystemClassLoader[307 modules]; see http://wiki.netbeans.org/DevFaqModuleCCE
schkovich@schkovich:~$ tail -f .netbeans/dev/var/log/messages.log
	at $Proxy17.getLogMessages(Unknown Source)
[catch] at org.netbeans.modules.subversion.ui.copy.MergeAction.performMerge(MergeAction.java:200)
	at org.netbeans.modules.subversion.ui.copy.MergeAction.access$000(MergeAction.java:69)
	at org.netbeans.modules.subversion.ui.copy.MergeAction$1.perform(MergeAction.java:133)
	at org.netbeans.modules.subversion.client.SvnProgressSupport.performIntern(SvnProgressSupport.java:109)
	at org.netbeans.modules.subversion.client.SvnProgressSupport.run(SvnProgressSupport.java:102)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032)
WARNING [org.netbeans.ProxyClassLoader]: Will not load class org.tigris.subversion.svnclientadapter.javahl.AbstractJhlClientAdapter arbitrarily from one of ModuleCL@fb5265f[org.netbeans.libs.svnClientAdapter.svnkit] and ModuleCL@3dea2f07[org.netbeans.libs.svnClientAdapter.javahl] starting from SystemClassLoader[307 modules]; see http://wiki.netbeans.org/DevFaqModuleCCE
WARNING [org.netbeans.ProxyClassLoader]: Will not load class org.apache.subversion.javahl.SVNClient arbitrarily from one of ModuleCL@fb5265f[org.netbeans.libs.svnClientAdapter.svnkit] and ModuleCL@3dea2f07[org.netbeans.libs.svnClientAdapter.javahl] starting from SystemClassLoader[307 modules]; see http://wiki.netbeans.org/DevFaqModuleCCE

How to reproduce:
Hard. :) I hope that details on my setup will be helpful. 
Problem occurred after upgrading subversion and dependencies from Ubuntu default 1.6.4 to 1.7.4 obtained from https://launchpad.net/~dominik-stadler/+archive/subversion-1.7
Upgrade procedure went well. I was asked to upgrade working copy and then to switch from cli to javahl implementation.
svn merge from command line works as expected.

Please let me know if I can provide further information. 

Setup details:
Product Version: NetBeans IDE Dev (Build 201205040400)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17
System: Linux version 3.0.0-19-generic running on amd64; UTF-8; en_US (nb)

svn, version 1.7.4 (r1295709) compiled Mar 17 2012, 12:27:32

org.netbeans.libs.svnClientAdapter.javahl/1 [1.8 201205040400]
INFO [org.netbeans.modules.subversion.client.SvnClientFactory]: running on javahl
Comment 1 Ondrej Vrabec 2012-05-05 17:43:47 UTC
fix: core-main #61cb7c4871ec
Comment 2 Quality Engineering 2012-05-06 09:50:56 UTC
Integrated into 'main-golden', will be available in build *201205060400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/61cb7c4871ec
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #212120 - Cannot merge changes from the trunk into working copy
Comment 3 schkovich 2012-05-06 17:36:39 UTC
Works as expected.

Product Version: NetBeans IDE Dev (Build 201205060400)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17
System: Linux version 3.0.0-19-generic running on amd64; UTF-8; en_US (nb)
Comment 4 Ondrej Vrabec 2012-06-01 08:15:33 UTC
*** Bug 213263 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo