Bug 212073 - NullPointerException at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.getFileObject
NullPointerException at org.netbeans.modules.masterfs.filebasedfs.fileobjects...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT
:
: 212447 212753 213062 (view as bug list)
Depends on: 213014
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 10:09 UTC by stefan79
Modified: 2012-06-01 21:50 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (10.03 KB, text/plain)
2012-05-04 10:09 UTC, stefan79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefan79 2012-05-04 10:09:39 UTC
This bug was originally marked as duplicate of bug 209466, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201205010400)
VM: Java HotSpot(TM) 64-Bit Server VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b05
OS: Windows 7

User Comments:
stefan79: Pressed F9 at JUnit-Test-File




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.getFileObject(FolderObj.java:126)
   at org.netbeans.modules.project.ant.AntBasedProjectFactorySingleton.loadProject(AntBasedProjectFactorySingleton.java:227)
   at org.netbeans.api.project.ProjectManager.createProject(ProjectManager.java:365)
   at org.netbeans.api.project.ProjectManager.access$300(ProjectManager.java:85)
   at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:286)
   at org.netbeans.api.project.ProjectManager$2.run(ProjectManager.java:233)
Comment 1 stefan79 2012-05-04 10:09:45 UTC
Created attachment 119078 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-05-21 07:29:16 UTC
Who knows what this could be caused by. Adding assert: ergonomics#4711f769da04
Comment 3 Jaroslav Tulach 2012-05-21 10:34:01 UTC
*** Bug 212447 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Tulach 2012-05-21 10:34:30 UTC
*** Bug 212753 has been marked as a duplicate of this bug. ***
Comment 5 Quality Engineering 2012-05-23 09:09:08 UTC
Integrated into 'main-golden', will be available in build *201205230300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4711f769da04
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #212073: More info if the factory is null
Comment 6 Jaroslav Tulach 2012-06-01 21:50:57 UTC
*** Bug 213062 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo