Bug 21207 - Incorrect handling of keyTyped in term: Ctrl-2, Ctrl-3
Incorrect handling of keyTyped in term: Ctrl-2, Ctrl-3
Status: VERIFIED DUPLICATE of bug 17337
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
PC Linux
: P4 (vote)
: 6.x
Assigned To: ivan
ivan
: A11Y
: 22523 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-05 17:01 UTC by Jesse Glick
Modified: 2008-12-23 08:19 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2002-03-05 17:01:31 UTC
[dev mar 01] It seems that term traps keyPressed and keyReleased,
perhaps, or anyway does not interact properly with the focus manager
as far as global keystrokes - it gets modifier-less keystrokes that
should have been consumed. Example: run some process which produces a
lot of output in the term window, which has focus. Press Page Up a
couple of times to look at output near, but not at, the end. Now press
Ctrl-3 to jump to sources. The Ctrl-3 works - you do jump to the
source window - but in the meantime the terminal window scrolls back
to the end and a "3" appears at the end of the output. This happens to
me reproducibly. It is an A11Y bug because from the keyboard you
cannot easily jump away from the term window while leaving it scrolled
somewhere other than the end of the output; you need to change the
window focus with the mouse, or use Alt-V and the View menu to switch.
(Pressing Alt-V does *not* leave a "v" in the term window.)
Comment 1 akemr 2002-03-07 09:00:18 UTC
I can reprodce it on Linux (but on Win2K it works fine!)
Simply run:
  for (int i=0; i<10000; i++)
      System.out.println("" + i);
and follow Jesse's steps.

OW sends Ctrl-2, Ctrl-3 to term as part of NB KeyStrokeSet,
so I'm reassigning.

BTW - this bug looks like duplicate of #17337, doesn't it?
Comment 2 Jesse Glick 2002-03-07 10:09:35 UTC
Yeah, I think it may be a dupe of #17337.
Comment 3 akemr 2002-04-17 09:45:38 UTC
*** Issue 22523 has been marked as a duplicate of this issue. ***
Comment 4 Marek Grummich 2002-07-22 08:46:29 UTC
Target milestone was changed from '3.4' to TBD.
Comment 5 Marek Grummich 2002-07-22 08:58:45 UTC
Target milestone was changed from '3.4' to TBD.
Comment 6 Marek Grummich 2002-07-22 09:05:18 UTC
Target milestone was changed from '3.4' to TBD.
Comment 7 Marek Grummich 2002-07-22 09:20:32 UTC
Target milestone was changed from '3.4' to TBD.
Comment 8 ivan 2003-03-27 02:54:20 UTC

*** This issue has been marked as a duplicate of 17337 ***
Comment 9 Lukas Hasik 2003-07-16 16:18:44 UTC
verified
Comment 10 Quality Engineering 2008-12-23 08:19:30 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo