Bug 211777 - Notify users if has not write permission for install global modules
Notify users if has not write permission for install global modules
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Manager
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Jiri Rechtacek
au-issues
: API, API_REVIEW_FAST, UI
: 203138 (view as bug list)
Depends on: 212218
Blocks: 197661 198739
  Show dependency treegraph
 
Reported: 2012-04-26 11:04 UTC by Jiri Rechtacek
Modified: 2012-05-18 13:18 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2012-04-26 11:04:21 UTC
If a module has set nbm.is.global=true (or it's fixed module?) and currently running intance of IDE has no permission to write to installation directory then Plugin Manager show a notification of this fact and recommends to run IDE with administrator role.
Comment 1 Jiri Rechtacek 2012-04-26 12:12:01 UTC
*** Bug 203138 has been marked as a duplicate of this bug. ***
Comment 2 Quality Engineering 2012-05-17 15:40:27 UTC
Integrated into 'main-golden', will be available in build *201205170950* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e2989a544b09
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #211777: added more tests


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo