Bug 211759 - AssertionError at org.netbeans.modules.csl.editor.hyperlink.GoToSupport.getIdentifierSpan
AssertionError at org.netbeans.modules.csl.editor.hyperlink.GoToSupport.getId...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: CSL (API & infrastructure)
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Svata Dedic
issues@editor
EXCEPTIONS_REPORT
:
: 212575 213367 214063 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-26 07:18 UTC by KhArtNJava
Modified: 2012-06-13 12:34 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.14 KB, text/plain)
2012-04-26 07:18 UTC, KhArtNJava
Details
stacktrace (3.14 KB, text/plain)
2012-05-03 09:11 UTC, schkovich
Details
stacktrace (3.14 KB, text/plain)
2012-05-23 14:31 UTC, schkovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description KhArtNJava 2012-04-26 07:18:07 UTC
Build: NetBeans IDE Dev (Build 201204240400)
VM: Java HotSpot(TM) Client VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b05
OS: Windows 7

Stacktrace: 
java.lang.AssertionError
   at org.netbeans.modules.csl.editor.hyperlink.GoToSupport.getIdentifierSpan(GoToSupport.java:346)
   at org.netbeans.modules.csl.editor.hyperlink.GsfHyperlinkProvider.getHyperlinkSpan(GsfHyperlinkProvider.java:77)
   at org.netbeans.lib.editor.hyperlink.HyperlinkOperation.performHyperlinking(HyperlinkOperation.java:248)
   at org.netbeans.lib.editor.hyperlink.HyperlinkOperation.keyPressed(HyperlinkOperation.java:401)
   at java.awt.AWTEventMulticaster.keyPressed(AWTEventMulticaster.java:249)
   at java.awt.AWTEventMulticaster.keyPressed(AWTEventMulticaster.java:249)
Comment 1 KhArtNJava 2012-04-26 07:18:13 UTC
Created attachment 118785 [details]
stacktrace
Comment 2 schkovich 2012-05-03 09:11:31 UTC
Created attachment 119008 [details]
stacktrace

invoking codecompletion ctrl+space
Comment 3 schkovich 2012-05-23 14:31:42 UTC
Created attachment 119777 [details]
stacktrace

copy/paste
Comment 4 Svata Dedic 2012-05-24 13:42:48 UTC
Changeset: 21cf44163277
Author:    Svata Dedic <sdedic@netbeans.org>
Date:      2012-05-24 15:42
Message:   Issue #211759 - AssertionError at org.netbeans.modules.csl.editor.hyperlink.GoToSupport.getIdentifierSpan: fixed
The hyperlink paint should be done under read-lock. Changed assert to a WARN log, to avoid assert suppression in release.
Comment 5 Milutin Kristofic 2012-06-04 16:36:01 UTC
*** Bug 213367 has been marked as a duplicate of this bug. ***
Comment 6 Milutin Kristofic 2012-06-04 16:36:23 UTC
*** Bug 212575 has been marked as a duplicate of this bug. ***
Comment 7 Milutin Kristofic 2012-06-13 12:34:33 UTC
*** Bug 214063 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo