Bug 211744 - IllegalStateException: No instance data can be specified.
IllegalStateException: No instance data can be specified.
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Netigso
7.2
All All
: P1 (vote)
: 7.2
Assigned To: Jaroslav Tulach
issues@platform
EXCEPTIONS_REPORT 7.2Beta-stopper-fixed
:
: 211822 211833 211909 211950 211955 (view as bug list)
Depends on:
Blocks: 209643 211353 211733 211773 211830 211838 211840
  Show dependency treegraph
 
Reported: 2012-04-25 22:21 UTC by Jesse Glick
Modified: 2012-10-10 07:35 UTC (History)
16 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (12.89 KB, text/plain)
2012-04-25 22:21 UTC, Jesse Glick
Details
bugzilla init test (4.41 KB, patch)
2012-04-26 11:53 UTC, Tomas Stupka
Details | Diff
stacktrace (1.69 KB, text/plain)
2012-04-27 05:02 UTC, alied
Details
stacktrace (4.68 KB, text/plain)
2012-04-27 06:47 UTC, Tomas Mysik
Details
stacktrace (4.66 KB, text/plain)
2012-05-01 08:29 UTC, Ralph Ruijs
Details
stacktrace (4.66 KB, text/plain)
2012-05-01 13:35 UTC, schkovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-04-25 22:21:00 UTC
Build: NetBeans IDE Dev (Build 20120425-03ec8561ca75)
VM: Java HotSpot(TM) Client VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b04
OS: Linux

Stacktrace: 
java.lang.IllegalStateException: No instance data can be specified.
   at org.eclipse.core.internal.runtime.DataArea.assertLocationInitialized(DataArea.java:50)
   at org.eclipse.core.internal.runtime.DataArea.getStateLocation(DataArea.java:120)
   at org.eclipse.core.internal.runtime.InternalPlatform.getStateLocation(InternalPlatform.java:606)
   at org.eclipse.core.internal.runtime.InternalPlatform.getStateLocation(InternalPlatform.java:601)
   at org.eclipse.core.runtime.Platform.getStateLocation(Platform.java:1009)
   at org.eclipse.mylyn.internal.bugzilla.core.BugzillaCorePlugin.getConfigurationCachePath(BugzillaCorePlugin.java:66)
Comment 1 Jesse Glick 2012-04-25 22:21:05 UTC
Created attachment 118769 [details]
stacktrace
Comment 2 Jesse Glick 2012-04-25 22:29:17 UTC
Bugzilla basically seems broken in this build.
Comment 3 Tomas Stupka 2012-04-26 09:42:27 UTC
bugzilla as well as JIRA. happens every time when runtime.Platform.getStateLocation() is called.please evaluate ...
Comment 4 Tomas Stupka 2012-04-26 11:53:46 UTC
Created attachment 118802 [details]
bugzilla init test

might not be the last time something like this happens. 
See attachment for suggested test to prevent such cases in the future ...
Comment 5 Jaroslav Tulach 2012-04-26 13:44:11 UTC
ergonomics#a353da65c6e
Comment 6 Jesse Glick 2012-04-26 18:15:11 UTC
Check for possible relation to bug #209691, bug #211773, bug #211353.
Comment 7 alied 2012-04-27 05:02:26 UTC
Created attachment 118836 [details]
stacktrace

On the Exception Reporter clicked on the bug id link
Comment 8 Tomas Mysik 2012-04-27 06:47:27 UTC
Created attachment 118849 [details]
stacktrace

just wanted to see a bug in the ide
Comment 9 Tomas Stupka 2012-04-27 11:07:40 UTC
*** Bug 211822 has been marked as a duplicate of this bug. ***
Comment 10 Tomas Stupka 2012-04-27 11:07:55 UTC
*** Bug 211833 has been marked as a duplicate of this bug. ***
Comment 11 Marian Mirilovic 2012-04-27 12:02:53 UTC
Stopper for Beta
Comment 12 Ralph Ruijs 2012-05-01 08:29:29 UTC
Created attachment 118918 [details]
stacktrace
Comment 13 schkovich 2012-05-01 13:35:30 UTC
Created attachment 118922 [details]
stacktrace

hmhhh... bugzilla has the same problem?
Comment 14 Jaroslav Tulach 2012-05-02 08:52:43 UTC
changeset:   ac51b45b3879
branch:      release72_beta
tag:         tip
parent:      3a5fd6b20cb3
parent:      a353da65c6ed
user:        Jaroslav Tulach <jtulach@netbeans.org>
date:        Wed May 02 10:51:33 2012 +0200
summary:     Merge of #211744 to 7.2 beta branch
Comment 15 Tomas Stupka 2012-05-02 09:52:44 UTC
*** Bug 211909 has been marked as a duplicate of this bug. ***
Comment 16 Quality Engineering 2012-05-02 10:05:41 UTC
Integrated into 'main-golden', will be available in build *201205020400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a353da65c6ed
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #211744: osgi.instance.area needs to be defined otherwise o.e.c.runtime.Platform throws ISE and bugzilla does not work
Comment 17 Tomas Stupka 2012-05-02 10:58:42 UTC
*** Bug 211950 has been marked as a duplicate of this bug. ***
Comment 18 Tomas Stupka 2012-05-02 11:17:44 UTC
*** Bug 211955 has been marked as a duplicate of this bug. ***
Comment 19 Quality Engineering 2012-10-10 07:35:09 UTC
Integrated into 'releases', will be available in build *201210100002* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/ac51b45b3879
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: Merge of #211744 to 7.2 beta branch


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo