Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 211463 - JDK crash when accessing Gnome keyring with 32bit Java on 64bit system (e.g. expand Services/Databases)
JDK crash when accessing Gnome keyring with 32bit Java on 64bit system (e.g. ...
Status: RESOLVED DUPLICATE of bug 211403
Product: platform
Classification: Unclassified
Component: Options&Settings
7.1
PC Linux
: P1 (vote)
: 7.2
Assigned To: Jiri Rechtacek
issues@platform
:
: 213810 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 14:05 UTC by Marian Mirilovic
Modified: 2012-06-08 12:02 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
JVM rash log (68.99 KB, text/x-log)
2012-04-19 14:05 UTC, Marian Mirilovic
Details
log from 32b OS (64.65 KB, text/x-log)
2012-04-23 08:10 UTC, Vladimir Riha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2012-04-19 14:05:33 UTC
Created attachment 118520 [details]
JVM rash log

JDK bundle 7u4 & NB 7.1.2

- installed both
- opened some J2SE projects
- selected Services View
-> JDK crashed (see attached log file)
Comment 1 Marian Mirilovic 2012-04-19 14:05:56 UTC
I am not able to reproduce it
Comment 2 Marian Mirilovic 2012-04-19 14:07:12 UTC
no sorry .. I am able to reproduce it 100% : 
- just expand Databases node and IDE will crash (5 from 5 times)
Comment 3 Antonin Nebuzelsky 2012-04-19 14:34:01 UTC
More evaluation on Marian's computer - happens with JDK 7u4, but does not happen with JDK 7u3.

Jesse, which part of our interaction with the gnome keyring library is causing it? Any clue why it starts crashing only with 7u4?
Comment 4 Marian Mirilovic 2012-04-19 15:16:45 UTC
... and more evaluation :
- running 64b system & 32b JDK seems to be key combination :

I am running Ubuntu 11.10 x64 , Gnome :
.... 7u4 b20/b19 , 6u32 b05 - all 32b -> crash
.... 7u4 b20/b19 , 6u32 b05 - all 64b -> works without problem
Comment 5 Antonin Nebuzelsky 2012-04-19 15:28:55 UTC
(In reply to comment #3)
> More evaluation on Marian's computer - happens with JDK 7u4, but does not
> happen with JDK 7u3.

Not true. Jirka reproduced on his 64bit Ubuntu with 7u3 32bit + 7.1.1 (the previous JDK bundle).

As Marian notes above, it is 32bit Java on 64bit Ubuntu which is the key.
Comment 6 Marian Mirilovic 2012-04-19 15:30:19 UTC
Release Note for NB 7.1.2 :
IDE crashes when user runs any operation using keyring when running 32b JDK on 64b Ubuntu. Workaround : use 64b JDK on 64b Ubuntu.
Comment 7 Antonin Nebuzelsky 2012-04-19 15:48:56 UTC
Will try if JNA 3.4 will help (issue 211403).
Comment 8 Jesse Glick 2012-04-19 17:44:15 UTC
I use a 32-bit JDK on 64-bit Ubuntu every day without problems.

Using "Linux jglick-t400 3.0.0-17-generic #30-Ubuntu SMP Thu Mar 8 20:45:39 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux", I downloaded jdk-7u4-fcs-bin-b20-linux-i586-12_apr_2012.tar.gz and tried running 20120419-72fa32370df8 and expanding the Databases node - no crash.
Comment 9 Jiri Kovalsky 2012-04-19 17:53:12 UTC
I can also reproduce it 100%. Seems like a duplicate of my bug #209226.
Comment 10 Jesse Glick 2012-04-19 18:15:00 UTC
netbeans-7.1.2-ml-javase-linux.sh worked fine too.

Maybe someone who can reproduce this (at least occasionally) can help debug it; I cannot do anything based on the crash report.

Without an evaluation of what is wrong, I do not think we can say that the problem is in fact JDK-specific. Nor is a release note in order for a P1 bug unless we know why it happens and that we cannot prevent it, especially when it is suggested that there is no recent regression in NetBeans itself.
Comment 11 Vladimir Riha 2012-04-19 18:28:01 UTC
It happens to me on Ubuntu 11.10 32b & 32b JDK 7u4 with trunk builds and latest 7.1.2 (I switched from 64b Ubuntu because I thought it will help but it didn't)
Comment 12 Jiri Kovalsky 2012-04-19 19:40:08 UTC
BTW, for me it also happens with JDK 6 Update 32. I installed 7.1.2 SE & 6_32 bundle, installed Java Web Applications plugin, restarted IDE and now every attempt to open JSPExamples application [1] crashes the IDE.

[1] http://wiki.netbeans.org/wiki/images/c/c6/JSPExamples.zip

Product Version: NetBeans IDE 7.1.2 (Build 201204101705)
Java: 1.6.0_32; Java HotSpot(TM) Client VM 20.7-b02
System: Linux version 3.0.0-12-generic running on i386; UTF-8; cs_CZ (nb)
User directory: /home/cesilko/.netbeans/7.1.2
Cache directory: /home/cesilko/.netbeans/7.1.2/var/cache
Comment 13 Vladimir Riha 2012-04-23 08:10:24 UTC
Created attachment 118612 [details]
log from 32b OS

(In reply to comment #11)
> It happens to me on Ubuntu 11.10 32b & 32b JDK 7u4 with trunk builds and latest
> 7.1.2 (I switched from 64b Ubuntu because I thought it will help but it didn't)

I can't reproduce it in latest trunk (perhaps #211401 fixed it?), here's log from build 201204170400 on 32b OS


Product Version: NetBeans IDE Dev (Build 201204170400)
Java: 1.7.0_04; Java HotSpot(TM) Client VM 23.0-b21
System: Linux version 3.0.0-17-generic-pae running on i386; UTF-8; en_US (nb)
Comment 14 Jiri Kovalsky 2012-04-23 09:29:27 UTC
I also confirm that the latest dev build does neither crash when saving password to the keyring nor when opening web application!

Product Version: NetBeans IDE Dev (Build 201204220400)
Java: 1.7.0_04; Java HotSpot(TM) 64-Bit Server VM 23.0-b21
System: Linux version 3.0.0-12-generic running on amd64; UTF-8; cs_CZ (nb)
User directory: /home/cesilko/.netbeans/dev
Cache directory: /home/cesilko/.cache/netbeans/dev
Comment 15 Jiri Rechtacek 2012-04-23 11:21:50 UTC
I can confirm it is not reproducible on latest Dev build IDE (Product Version = NetBeans IDE Dev (Build 201204230400) (#6894fc2ff9d3)).

The older builds (e.g. Product Version = NetBeans IDE Dev (Build 201204190400) (#83b5156ac3f7)) crashes  every time when accessing Keyring on my machine. I think the newer JNA 3.4 solved this problem and we can close as fixed. Am I wrong?
Comment 16 Jesse Glick 2012-04-23 13:08:50 UTC
(In reply to comment #15)
> I think the newer JNA 3.4 solved this problem

Perhaps. No one knows what the problem was, and what particular change in JNA might have corrected it, or whether the problem disappeared (for now?) for some other reason.
Comment 17 Jiri Rechtacek 2012-04-23 13:13:20 UTC
(In reply to comment #15)
> I can confirm it is not reproducible on latest Dev build IDE (Product Version =
> NetBeans IDE Dev (Build 201204230400) (#6894fc2ff9d3)).
> 
> The older builds (e.g. Product Version = NetBeans IDE Dev (Build 201204190400)
> (#83b5156ac3f7)) crashes  every time when accessing Keyring on my machine. I
> think the newer JNA 3.4 solved this problem and we can close as fixed. Am I
> wrong?

Mark as fixed by #rev/836f5c2762c5. If the problem appears again, please reopen it with all available details. Thanks
Comment 18 Jesse Glick 2012-04-23 13:16:47 UTC

*** This bug has been marked as a duplicate of bug 211403 ***
Comment 19 ttokoly 2012-04-24 14:22:20 UTC
Product Version: NetBeans IDE 7.1.2 (Build 201204101705)
Java: 1.7.0_04; Java HotSpot(TM) Client VM 23.0-b21
System: Linux version 2.6.38-8-generic running on i386; UTF-8; en_US (nb)

1. downloaded jdk-7u4-nb-7_1_2-linux-ml.sh from http://smetiste.cz.oracle.com/builds/netbeans/7.1.2/bundles/jdk-7u4-nb-7_1_2/2012-04-17_21-48-09/
2. installed jdk-7u4-nb-7_1_2-linux-ml.sh
3. opened some J2SE projects
4. selected Services view
5. expanded Databases node

-> everything seems fine

Tested on Ubuntu 11.04 32b (in VirtualBox that runs on Linux Ubuntu 11.10 32b), downloaded from beetle.cz.oracle.com (Linux_Ubuntu_Machine.vdi.zip).
Comment 20 Jesse Glick 2012-04-24 17:06:58 UTC
BTW the most direct way to check a given OS/JDK/NB combination is

$ ant -f keyring.impl -Dnbjdk.home=... -Dpermit.jdk7.builds=true -Dtest.includes=org/netbeans/modules/keyring/gnome/GnomeProviderTest.java test-single

(This will check functionality more thoroughly than just expanding Databases, which only happens to use the keyring at all due to a bug in the current database support, and merely reads a certain key without writing anything.) If all is well you should see

Testsuite: org.netbeans.modules.keyring.gnome.GnomeProviderTest
Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 4.058 sec

If the test fails, or passes but prints "org.netbeans.modules.keyring.gnome.GnomeProvider@3eda834c disabled on Linux, skipping", then the provider is broken.
Comment 21 Marian Mirilovic 2012-06-08 12:02:31 UTC
*** Bug 213810 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo