Bug 211425 - java.util.ConcurrentModificationException at java.util.ArrayList$Itr.checkForComodification
java.util.ConcurrentModificationException at java.util.ArrayList$Itr.checkFor...
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Editor
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Ondrej Brejla
issues@php
EXCEPTIONS_REPORT
:
: 211426 211434 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 08:06 UTC by schkovich
Modified: 2012-04-21 09:57 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.01 KB, text/plain)
2012-04-19 08:06 UTC, schkovich
Details
stacktrace (4.75 KB, text/plain)
2012-04-19 09:08 UTC, schkovich
Details
stacktrace (4.88 KB, text/plain)
2012-04-19 19:53 UTC, leek
Details
stacktrace (4.88 KB, text/plain)
2012-04-20 20:23 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-04-19 08:06:03 UTC
Build: NetBeans IDE Dev (Build 201204181547)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: double clicking on the file in the Files pannel




Stacktrace: 
java.util.ConcurrentModificationException
   at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:819)
   at java.util.ArrayList$Itr.next(ArrayList.java:791)
   at org.netbeans.modules.php.editor.model.impl.ModelVisitor.handleVarComment(ModelVisitor.java:1311)
   at org.netbeans.modules.php.editor.model.impl.ModelVisitor.handleVarComments(ModelVisitor.java:1303)
   at org.netbeans.modules.php.editor.model.impl.ModelVisitor.visit(ModelVisitor.java:322)
   at org.netbeans.modules.php.editor.parser.astnodes.Program.accept(Program.java:92)
Comment 1 schkovich 2012-04-19 08:06:10 UTC
Created attachment 118486 [details]
stacktrace
Comment 2 Ondrej Brejla 2012-04-19 08:16:26 UTC
*** Bug 211426 has been marked as a duplicate of this bug. ***
Comment 3 Ondrej Brejla 2012-04-19 08:16:53 UTC
Cn you provide me that file, where the problem occurs? It will help me a lot.
Comment 4 schkovich 2012-04-19 09:08:27 UTC
Created attachment 118494 [details]
stacktrace

saving edited file
Comment 5 Ondrej Brejla 2012-04-19 09:24:16 UTC
*** Bug 211434 has been marked as a duplicate of this bug. ***
Comment 6 Ondrej Brejla 2012-04-19 15:40:31 UTC
Will fix it probably tomorrow.
Comment 7 leek 2012-04-19 19:53:24 UTC
Created attachment 118538 [details]
stacktrace

Another Netbeans crash
Comment 8 Ondrej Brejla 2012-04-20 10:17:12 UTC
Fixed in web-main #e967b2618e6f
Comment 9 Exceptions Reporter 2012-04-20 20:23:26 UTC
Created attachment 118577 [details]
stacktrace

1st start after upgrade from 7.1.1
Comment 10 Quality Engineering 2012-04-21 09:57:32 UTC
Integrated into 'main-golden', will be available in build *201204210400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/e967b2618e6f
User: Ondrej Brejla <obrejla@netbeans.org>
Log: #211425 - java.util.ConcurrentModificationException at java.util.ArrayList$Itr.checkForComodification


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo