Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 211401 - Keyring integration missing in Ubuntu 12.04
Keyring integration missing in Ubuntu 12.04
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Options&Settings
7.1
PC Linux
: P2 (vote)
: 7.2
Assigned To: Jesse Glick
issues@platform
:
Depends on: 211403
Blocks: 203735
  Show dependency treegraph
 
Reported: 2012-04-18 14:59 UTC by Jesse Glick
Modified: 2012-06-16 21:53 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2012-04-18 14:59:32 UTC
Cannot load libgnome-keyring.so. Fix of bug #203735 made it look in /usr/lib/libgnome-keyring.so.0 but (I guess due to ongoing multiarch work) it is now in /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 on i1386.
Comment 1 Jesse Glick 2012-04-18 15:09:08 UTC
core-main #941a305500da
Comment 2 Quality Engineering 2012-04-20 10:09:51 UTC
Integrated into 'main-golden', will be available in build *201204200400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/941a305500da
User: Jesse Glick <jglick@netbeans.org>
Log: #211401: Keyring integration missing in Ubuntu 12.04
Comment 3 Quality Engineering 2012-04-22 09:49:28 UTC
Integrated into 'main-golden', will be available in build *201204220400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/012ce3fc5582
User: Jesse Glick <jglick@netbeans.org>
Log: Backing out #211401 fix in favor of using JNA 3.4 (#211403).
Comment 4 Jesse Glick 2012-05-02 16:18:01 UTC
Are you sure this fix is a patch 3 candidate, given that I backed it out again in trunk since the fix of bug #211403 supersedes it?
Comment 5 Marian Mirilovic 2012-05-02 16:54:40 UTC
(In reply to comment #4)
> Are you sure this fix is a patch 3 candidate, given that I backed it out again
> in trunk since the fix of bug #211403 supersedes it?

My fault, sorry you are right.
Comment 6 everflux 2012-06-16 21:46:11 UTC
Running Ubuntu 12.04 with 64bit the keyring integration seems to be broken again.
Testing with Netbeans 7.2 RC1 (netcat build 201206141830)

Path on 64bit machine is:
/usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0
Comment 7 everflux 2012-06-16 21:53:40 UTC
Maybe this was a false positive, I restarted Netbeans 7.2rc1 with debugging enabled and it worked. (Maybe migration of 7.1 settings was the cause?)

FINE [org.netbeans.modules.keyring.kde.KWalletProvider]: executing [qdbus, org.kde.kwalletd, /modules/kwalletd, org.kde.KWallet.isEnabled]
FINE [org.netbeans.modules.keyring.kde.KWalletProvider]: application exit with code 2 for commandString: [qdbus, org.kde.kwalletd, /modules/kwalletd, org.kde.KWallet.isEnabled]; errVal: Service 'org.kde.kwalletd' does not exist.
FINE [org.netbeans.modules.keyring]: Using provider: org.netbeans.modules.keyring.gnome.GnomeProvider@3ed45cce

Saved password is used as it should when using a git pull.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo