Bug 211235 - Newly added template does not appear in Template Manager, sometimes.
Newly added template does not appear in Template Manager, sometimes.
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Templates
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Martin Entlicher
issues@platform
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-16 09:10 UTC by Martin Entlicher
Modified: 2012-04-18 21:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Entlicher 2012-04-16 09:10:47 UTC
Sometimes, when a new template is added in Template Manager, it does not appear in the list, although it's actually added.
This is caused by different threading.
createTemplateFromFile() creates the template via sourceDO.copy(folder) (which fires changes and attempts to add the newly created node) and then sets template.setTemplate(true);
Depending on whether template.setTemplate(true) happens to be called sooner than TemplateFilter.acceptTemplate() checks it, the newly added template file shows up, or not.
Comment 1 Martin Entlicher 2012-04-17 15:22:07 UTC
Fixed by changeset:   219069:a1eb663cef3b
http://hg.netbeans.org/main/rev/a1eb663cef3b
Comment 2 Quality Engineering 2012-04-18 21:27:25 UTC
Integrated into 'main-golden', will be available in build *201204181547* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a1eb663cef3b
User: mentlicher@netbeans.org
Log: #211235: Assure, that the templates list is refreshed when file template attribute changes.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo