Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 211076 - Change the way we brand the IDE
Change the way we brand the IDE
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: UI
7.2
All All
: P3 with 3 votes (vote)
: 7.4
Assigned To: Petr Somol
issues@ide
issue_reviewed
:
Depends on: 211796
Blocks: 211049
  Show dependency treegraph
 
Reported: 2012-04-12 09:29 UTC by Marian Mirilovic
Modified: 2013-07-11 08:20 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2012-04-12 09:29:40 UTC
We are having problems (means getting a lot of negative feedback) after releasing patches that says : no change in splash screen... see issue 208627 ... and please use THAT issue for any further discussion, do not put it here, thanks in advance.

The possible solution would be to change the way we use branding ... change the version number in splash screen and use text field instead of graphic, text read from bundle :
- we can stay with one graphic for the whole release (no changes in pictures during a release cycle)
- also we might put there more than just a number

So for example :
- start to work on 7.2 ...
- development builds .... splash says NetBeans "7.2 Development Version"
- Beta .... splash says NetBeans "7.2 Beta"
- RCs .... splash says NetBeans "7.2 RC 1" .... RC X
- releasing major release 7.2 ... splash says NetBeans "7.2"
- building 7.2.1 .... splash says NetBeans "7.2.1 Development Version"
- releasing 7.2.1 ... splash says NetBeans "7.2.1"
- upgrade from 7.2 to 7.2.1 ... splash says NetBeans "7.2 with patch 1"
- building 7.2.2 .... splash says NetBeans "7.2.2 Development Version"
- releasing 7.2.2 ... splash says NetBeans "7.2.2"
- upgrade from 7.2 to 7.2.2 ... splash says NetBeans "7.2 with patch 2"
- upgrade from 7.2.1 to 7.2.2 ... splash says NetBeans "7.2.1 with patch 2"
Comment 1 Jiri Rechtacek 2012-04-17 10:19:12 UTC
I'm preparing a summary this issue and outline of possible solutions. I'll add the link here soon.
Comment 2 Antonin Nebuzelsky 2012-04-18 12:52:58 UTC
*** Bug 208627 has been marked as a duplicate of this bug. ***
Comment 3 host 2012-04-18 13:27:24 UTC
Marian, would you mind changing your issue to be a duplicate of my issue 208627? In that way we can keep the already existing discussion in one place. You could add your issue description there and change the title of issue 208627 appropriately. What do you think?
Comment 4 Marian Mirilovic 2012-04-19 06:15:48 UTC
(In reply to comment #3)
> Marian, would you mind changing your issue to be a duplicate of my issue
> 208627? In that way we can keep the already existing discussion in one place.
> You could add your issue description there and change the title of issue 208627
> appropriately. What do you think?

No, discussion should run in issue 208627. This is only placeholder for solutions we will do. At the end we will close (of-course) both issues as fixed.
Comment 5 Marian Mirilovic 2012-06-14 08:10:31 UTC
Not all cases closed to 7.2, leave it open for next release.
Comment 6 Petr Jiricka 2012-09-04 11:17:42 UTC
Any resolution planned for 7.3 beta?
Why is this a P1 defect?
Comment 7 Petr Jiricka 2012-09-11 15:44:44 UTC
No response after my last comment -> changing priority to P3. If this is required for 7.3, I would like to know what are the next steps, when and by whom.
Comment 8 Marian Mirilovic 2013-07-11 08:20:41 UTC
I haven't seen any negative feedback for a while, so assume we already addressed it. Thanks all for participation.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo