Bug 211002 - IllegalArgumentException: Parameter file was not normalized. Was ../../../../usr/share/php/PHPUnit instead of /usr/share/php/PHPUnit
IllegalArgumentException: Parameter file was not normalized. Was ../../../../...
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Project
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Tomas Mysik
issues@php
EXCEPTIONS_REPORT
:
: 211048 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 12:05 UTC by schkovich
Modified: 2012-04-13 09:49 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.25 KB, text/plain)
2012-04-11 12:06 UTC, schkovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-04-11 12:05:57 UTC
Build: NetBeans IDE Dev (Build 201204100400)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: Moving up include path definition in Project Properties > PHP Include Path




Stacktrace: 
java.lang.IllegalArgumentException: Parameter file was not normalized. Was ../../../../usr/share/php/PHPUnit instead of /usr/share/php/PHPUnit
   at org.openide.filesystems.FileUtil.toFileObject(FileUtil.java:1030)
   at org.netbeans.modules.php.project.ui.customizer.CustomizerPhpIncludePath.validateData(CustomizerPhpIncludePath.java:135)
   at org.netbeans.modules.php.project.ui.customizer.CustomizerPhpIncludePath$2.intervalAdded(CustomizerPhpIncludePath.java:105)
   at javax.swing.AbstractListModel.fireIntervalAdded(AbstractListModel.java:148)
   at javax.swing.DefaultListModel.add(DefaultListModel.java:481)
   at org.netbeans.modules.php.project.ui.PathUiSupport.moveUp(PathUiSupport.java:116)
Comment 1 schkovich 2012-04-11 12:06:03 UTC
Created attachment 118123 [details]
stacktrace
Comment 2 Tomas Mysik 2012-04-11 12:24:41 UTC
Fixed.

http://hg.netbeans.org/web-main/rev/7d45d57f99a9
Comment 3 Tomas Mysik 2012-04-12 04:36:08 UTC
*** Bug 211048 has been marked as a duplicate of this bug. ***
Comment 4 Quality Engineering 2012-04-13 09:49:36 UTC
Integrated into 'main-golden', will be available in build *201204130400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7d45d57f99a9
User: Tomas Mysik <tmysik@netbeans.org>
Log: #211002 - IllegalArgumentException: Parameter file was not normalized. Was ../../../../usr/share/php/PHPUnit instead of /usr/share/php/PHPUnit


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo