Bug 210976 - StringIndexOutOfBoundsException: String index out of range: 399
StringIndexOutOfBoundsException: String index out of range: 399
Status: RESOLVED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Marek Fukala
issues@javaee
EXCEPTIONS_REPORT
:
: 210616 211616 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 21:02 UTC by maxym
Modified: 2012-04-24 15:48 UTC (History)
22 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.25 KB, text/plain)
2012-04-10 21:02 UTC, maxym
Details
stacktrace (5.68 KB, text/plain)
2012-04-11 13:20 UTC, mrpc
Details
stacktrace (5.37 KB, text/plain)
2012-04-12 09:02 UTC, ehsavoie
Details
stacktrace (5.37 KB, text/plain)
2012-04-16 02:05 UTC, paolosca
Details
stacktrace (5.47 KB, text/plain)
2012-04-17 11:17 UTC, schkovich
Details
stacktrace (5.47 KB, text/plain)
2012-04-18 07:35 UTC, schkovich
Details
stacktrace (5.47 KB, text/plain)
2012-04-18 11:35 UTC, aws
Details
compile template smarty file (1.30 KB, text/x-php5)
2012-04-23 08:45 UTC, kaes1977
Details
stacktrace (5.16 KB, text/plain)
2012-04-24 12:23 UTC, Selpi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description maxym 2012-04-10 21:02:54 UTC
Build: NetBeans IDE Dev (Build 201204100400)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.1-b02, Java(TM) SE Runtime Environment, 1.6.0_26-b03
OS: Windows 7

User Comments:
GUEST: Starting NetBeans




Stacktrace: 
java.lang.StringIndexOutOfBoundsException: String index out of range: 399
   at java.lang.AbstractStringBuilder.substring(AbstractStringBuilder.java:0)
   at java.lang.StringBuilder.substring(StringBuilder.java:0)
   at java.lang.AbstractStringBuilder.subSequence(AbstractStringBuilder.java:0)
   at java.lang.StringBuilder.subSequence(StringBuilder.java:0)
   at org.netbeans.modules.html.parser.ElementsFactory$CommonAttribute.value(ElementsFactory.java:864)
   at org.netbeans.modules.html.parser.ElementsFactory$CommonAttribute.unquotedValue(ElementsFactory.java:883)
Comment 1 maxym 2012-04-10 21:02:59 UTC
Created attachment 118087 [details]
stacktrace
Comment 2 Marek Fukala 2012-04-11 08:58:47 UTC
Not clear to me how exactly the situation happens so I've added some diagnostic code and will close the issue as fixed. It will be automatically reopened or new one created next time the problem happens.

changeset:   219483:93305870588d
summary:     #210976 - StringIndexOutOfBoundsException: String index out of range: 399; #210909 - StringIndexOutOfBoundsException: String index out of range: 53 - adding some diagnostic code, not real fix!
Comment 3 maxym 2012-04-11 10:55:22 UTC
(In reply to comment #2)
> Not clear to me how exactly the situation happens 

Error appears while scanning projects, while the first run.
Comment 4 mrpc 2012-04-11 13:20:24 UTC
Created attachment 118127 [details]
stacktrace

I don't even know what happened... it was running on the background and when I switched back, I saw the error. The opened editor window had a css file.
Comment 5 ehsavoie 2012-04-12 09:02:22 UTC
Created attachment 118182 [details]
stacktrace
Comment 6 Quality Engineering 2012-04-12 09:56:52 UTC
Integrated into 'main-golden', will be available in build *201204120400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/93305870588d
User: Marek Fukala <mfukala@netbeans.org>
Log: #210976 - StringIndexOutOfBoundsException: String index out of range: 399; #210909 - StringIndexOutOfBoundsException: String index out of range: 53 - adding some diagnostic code, not real fix!
Comment 7 paolosca 2012-04-16 02:05:27 UTC
Created attachment 118291 [details]
stacktrace

Opened a php project, a few previously opened files opened automatically and the error popped up.
Comment 8 schkovich 2012-04-17 11:17:24 UTC
Created attachment 118393 [details]
stacktrace

scaning projects
Comment 9 schkovich 2012-04-18 07:35:27 UTC
Created attachment 118432 [details]
stacktrace

scanning project. there must be some file like sql dump, swf or some other binary file under version control that is causing the error. having option to ignore some folders during scanning might be interesting.
Comment 10 Marek Fukala 2012-04-18 08:52:53 UTC
Please try to use a build containing changeset http://hg.netbeans.org/web-main/rev/93305870588d (201204120400 or newer)
Comment 11 schkovich 2012-04-18 10:56:26 UTC
(In reply to comment #10)
> Please try to use a build containing changeset
> http://hg.netbeans.org/web-main/rev/93305870588d (201204120400 or newer)
I am using daily builds e.g. exception report was sent using build 201204170400.
Comment 12 aws 2012-04-18 11:35:28 UTC
Created attachment 118449 [details]
stacktrace
Comment 13 Marek Fukala 2012-04-18 12:15:17 UTC
fixed in web-main#d985ec214fd7

I haven't expected attribute values > than 32k
Comment 14 Marek Fukala 2012-04-18 13:07:48 UTC
*** Bug 210616 has been marked as a duplicate of this bug. ***
Comment 15 mfriedenhagen 2012-04-18 18:12:34 UTC
In regards to #11: will updating plugins be sufficient or do I need to download a complete nightly?
Comment 16 Quality Engineering 2012-04-19 10:02:32 UTC
Integrated into 'main-golden', will be available in build *201204190400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d985ec214fd7
User: Marek Fukala <mfukala@netbeans.org>
Log: #210976 - StringIndexOutOfBoundsException: String index out of range: 399
Comment 17 Marek Fukala 2012-04-19 13:17:31 UTC
>In regards to #11: will updating plugins be sufficient or do I need to download
>a complete nightly?

No version increased => download a complete build please.
Comment 18 kaes1977 2012-04-23 06:08:05 UTC
during downloading project on the new nightly build problem still occur
Comment 19 Marek Fukala 2012-04-23 07:02:48 UTC
(In reply to comment #18)
> during downloading project on the new nightly build problem still occur

please add the stacktrace.
Comment 20 Marek Fukala 2012-04-23 07:11:23 UTC
(In reply to comment #19)
> (In reply to comment #18)
> > during downloading project on the new nightly build problem still occur
> 
> please add the stacktrace.
disregard this. the stack is in the exception reports
Comment 21 Marek Fukala 2012-04-23 07:52:59 UTC
another attempt in web-main#bce59664b1e5, but not very likely it really fixes the problem.

kaes1977, would it be possible to find the file causing the exception. I'm afraid I'm bit out of ideas what can be the reason of the exception now. If it not possible, you could pack the whole project and attach it here or send it to me by email.
Comment 22 kaes1977 2012-04-23 08:45:15 UTC
This is a file which cause error for sure. This is templates compile file by SMARTY
Comment 23 kaes1977 2012-04-23 08:45:21 UTC
Created attachment 118615 [details]
compile template smarty file
Comment 24 Marek Fukala 2012-04-23 09:21:38 UTC
Reproducible using the attached file. Thank you
Comment 25 Marek Fukala 2012-04-23 10:06:18 UTC
now really fixed in web-main#c4fc37612939
Comment 26 Quality Engineering 2012-04-24 10:03:11 UTC
Integrated into 'main-golden', will be available in build *201204240400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/bce59664b1e5
User: Marek Fukala <mfukala@netbeans.org>
Log: #210976 - StringIndexOutOfBoundsException: String index out of range: 399
Comment 27 Selpi 2012-04-24 12:23:28 UTC
Created attachment 118687 [details]
stacktrace

Just a startup scan of several projects.
Comment 28 Marek Fukala 2012-04-24 15:48:00 UTC
*** Bug 211616 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo