Bug 210975 - Subversion commit extremely slow, while TortoiseSVN commit operates as expected
Subversion commit extremely slow, while TortoiseSVN commit operates as expected
Status: RESOLVED WORKSFORME
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.2
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 20:52 UTC by TomAuger
Modified: 2012-04-11 14:25 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Message log - Startup - Install Profiler Plugin - Run SVN Commit (206.23 KB, application/octet-stream)
2012-04-11 14:01 UTC, TomAuger
Details
Profiler dump - NB71 SVN commit (76.50 KB, application/octet-stream)
2012-04-11 14:05 UTC, TomAuger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description TomAuger 2012-04-10 20:52:38 UTC
Ran a commit on local working copy - 34 adds, 2 deletions, 8 mods (1 of the deletions was a large subdirectory). Using NetBeans Commit, this process took well over 10 minutes. Using TortoiseSVN directly on the local working copy took 23 seconds.

Not sure what NetBeans is up to there. Should I be checking anything?
Comment 1 TomAuger 2012-04-10 20:55:14 UTC
I should add that earlier I had done the "delete" on a subdirectory through NetBeans and that, too, took an inordinately long time. There were 200+ files in that subdirectory, but it took close to 10 minutes to perform the delete (also updating the status in SVN at the same time - which is a great feature, by the way!)
Comment 2 Ondrej Vrabec 2012-04-11 06:39:43 UTC
Is your checkout on an external drive? Attach also a profiler snapshot along with the message log while the long commit is in progress.
http://wiki.netbeans.org/FaqLogMessagesFile
http://wiki.netbeans.org/FitnessViaPartnership
Comment 3 TomAuger 2012-04-11 13:42:52 UTC
Checkout is on internal drive. System:
Win7 x64. Running local XAMPP server. NetBeans 7.1 project set up as a 'existing sources' project. Created the local working copy first using TortoiseSVN checkout process, then linked to the newly-created working directory with NB.
Comment 4 TomAuger 2012-04-11 14:01:37 UTC
Created attachment 118134 [details]
Message log - Startup - Install Profiler Plugin - Run SVN Commit

The commit was for a directory move operation. It's interesting to see in the message log a lot of "file not found" errors or warnings from the SVN module, even though the file WAS found, IS there, and the commit happened 100% (as far as I can tell).
Comment 5 TomAuger 2012-04-11 14:05:28 UTC
Created attachment 118135 [details]
Profiler dump - NB71 SVN commit

Started the Profiler log just before choosing the "SVN > commit" operation. Interesting that that UI gesture is not marked in the log, but it's right near the front. The elapsed time was certainly less than the previous commit that was the reason for this bug report HOWEVER it was also a much smaller change.

The previous commit was the removal of a directory with 100+ files in it. This one only affected 6 files in total. Yet the process still took a very long time.
Comment 6 TomAuger 2012-04-11 14:06:28 UTC
Thanks for the links to the Wiki articles. I don't think I would have been able to get you those logs unless I had the excellent instructions you provided. A+++!!
Comment 7 Ondrej Vrabec 2012-04-11 14:10:50 UTC
1) You're running with the commandline client, probably because of working with 1.7 repositories. This client is used only as a backup and suffers from a lot of performance issues: http://wiki.netbeans.org/FaqSubversion1_7. In 7.2 we support native subversion clients (javahl and subversion) - try a dev build: http://bits.netbeans.org/download/trunk/nightly/latest/
2) You're still on 7.1, there were some bugs regarding Subversion 1.7 support which should be fixed in 7.1.1, i suggest you download and use that version.

Please reopen with attached profiler snapshot and messages log from the dev 7.2 build if still reproducible.
Comment 8 Ondrej Vrabec 2012-04-11 14:25:45 UTC
Look also as bug #209126 which is probably about the same problem as yours, read my comment #3, you'll find several workarounds mentioned there.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo