Bug 210868 - Netbeans should allow 100% size applets
Netbeans should allow 100% size applets
Status: RESOLVED FIXED
Product: javafx
Classification: Unclassified
Component: Deployment
7.1
All All
: P3 (vote)
: 8.0
Assigned To: Roman Svitanic
issues@javafx
:
: 212566 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-08 11:42 UTC by Alexander Kouznetsov
Modified: 2013-11-27 14:55 UTC (History)
1 user (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2012-04-08 11:42:27 UTC
Currently Web Start and Web Browser application properties allow only absolute values for width and height. However it is necessary to support 100% width and 100% height applets.

Please see issue http://javafx-jira.kenai.com/browse/RT-16742

D:\JavaFX\repos\jfx\apps\internal\Set\nbproject\jfx-impl.xml:998: The following error occurred while executing this line:
D:\JavaFX\repos\jfx\apps\internal\Set\nbproject\jfx-impl.xml:625: 
java.lang.NumberFormatException: For input string: "100%"
	at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
	at java.lang.Integer.parseInt(Integer.java:492)
	at java.lang.Integer.valueOf(Integer.java:582)
	at com.sun.javafx.tools.ant.DeployFXTask.execute(DeployFXTask.java:103)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at sun.reflect.misc.Trampoline.invoke(MethodUtil.java:55)
	at sun.reflect.GeneratedMethodAccessor7.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at sun.reflect.misc.MethodUtil.invoke(MethodUtil.java:263)
	at sun.org.mozilla.javascript.internal.MemberBox.invoke(MemberBox.java:167)
	at sun.org.mozilla.javascript.internal.NativeJavaMethod.call(NativeJavaMethod.java:247)
	at sun.org.mozilla.javascript.internal.Interpreter.interpretLoop(Interpreter.java:1711)
	at sun.org.mozilla.javascript.internal.Interpreter.interpret(Interpreter.java:854)
	at sun.org.mozilla.javascript.internal.InterpretedFunction.call(InterpretedFunction.java:164)
	at sun.org.mozilla.javascript.internal.ContextFactory.doTopCall(ContextFactory.java:429)
	at com.sun.script.javascript.RhinoScriptEngine$1.superDoTopCall(RhinoScriptEngine.java:116)
	at com.sun.script.javascript.RhinoScriptEngine$1.access$200(RhinoScriptEngine.java:71)
	at com.sun.script.javascript.RhinoScriptEngine$1$1.run(RhinoScriptEngine.java:105)
	at java.security.AccessController.doPrivileged(Native Method)
	at com.sun.script.javascript.RhinoScriptEngine$1.doTopCall(RhinoScriptEngine.java:103)
	at sun.org.mozilla.javascript.internal.ScriptRuntime.doTopCall(ScriptRuntime.java:3163)
	at sun.org.mozilla.javascript.internal.InterpretedFunction.exec(InterpretedFunction.java:175)
	at sun.org.mozilla.javascript.internal.Context.evaluateReader(Context.java:1159)
	at com.sun.script.javascript.RhinoScriptEngine.eval(RhinoScriptEngine.java:210)
	at com.sun.script.javascript.RhinoScriptEngine.eval(RhinoScriptEngine.java:236)
	at javax.script.AbstractScriptEngine.eval(AbstractScriptEngine.java:264)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.apache.tools.ant.util.ReflectUtil.invoke(ReflectUtil.java:108)
	at org.apache.tools.ant.util.ReflectWrapper.invoke(ReflectWrapper.java:81)
	at org.apache.tools.ant.util.optional.JavaxScriptRunner.evaluateScript(JavaxScriptRunner.java:103)
	at org.apache.tools.ant.util.optional.JavaxScriptRunner.executeScript(JavaxScriptRunner.java:67)
	at org.apache.tools.ant.taskdefs.optional.Script.execute(Script.java:52)
	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
	at sun.reflect.GeneratedMethodAccessor812.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.taskdefs.Sequential.execute(Sequential.java:68)
	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
	at sun.reflect.GeneratedMethodAccessor812.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.taskdefs.MacroInstance.execute(MacroInstance.java:398)
	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
	at sun.reflect.GeneratedMethodAccessor812.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:390)
	at org.apache.tools.ant.Target.performTasks(Target.java:411)
	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
	at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:285)
	at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:539)
	at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:153)
Comment 1 Roman Svitanic 2013-11-21 16:35:41 UTC
http://hg.netbeans.org/jet-main/rev/2d56f8b113b4
Comment 2 Roman Svitanic 2013-11-27 14:55:23 UTC
*** Bug 212566 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo