Bug 210767 - StringIndexOutOfBoundsException: String index out of range: 803
StringIndexOutOfBoundsException: String index out of range: 803
Status: RESOLVED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Marek Fukala
issues@javaee
EXCEPTIONS_REPORT
:
: 210572 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 11:38 UTC by schkovich
Modified: 2012-04-07 10:26 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.58 KB, text/plain)
2012-04-05 11:38 UTC, schkovich
Details
stacktrace (5.36 KB, text/plain)
2012-04-05 13:17 UTC, host
Details
stacktrace (5.58 KB, text/plain)
2012-04-05 14:23 UTC, tomjnsn
Details
stacktrace (5.36 KB, text/plain)
2012-04-05 17:47 UTC, host
Details
stacktrace (5.37 KB, text/plain)
2012-04-07 10:26 UTC, host
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-04-05 11:38:53 UTC
Build: NetBeans IDE Dev (Build 201204040400)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: Scanning project. There must be some naughty file in the repository. :)

leek: Idling

troodon: editing javascript file




Stacktrace: 
java.lang.StringIndexOutOfBoundsException: String index out of range: 803
   at java.lang.AbstractStringBuilder.substring(AbstractStringBuilder.java:870)
   at java.lang.StringBuilder.substring(StringBuilder.java:72)
   at java.lang.AbstractStringBuilder.subSequence(AbstractStringBuilder.java:849)
   at java.lang.StringBuilder.subSequence(StringBuilder.java:72)
   at org.netbeans.modules.html.parser.ElementsFactory$CommonAttribute.value(ElementsFactory.java:849)
   at org.netbeans.modules.html.parser.ElementsFactory$CommonAttribute.isValueQuoted(ElementsFactory.java:857)
Comment 1 schkovich 2012-04-05 11:38:59 UTC
Created attachment 117886 [details]
stacktrace
Comment 2 host 2012-04-05 13:17:21 UTC
Created attachment 117893 [details]
stacktrace
Comment 3 tomjnsn 2012-04-05 14:23:22 UTC
Created attachment 117896 [details]
stacktrace
Comment 4 host 2012-04-05 17:47:21 UTC
Created attachment 117903 [details]
stacktrace
Comment 5 Marek Fukala 2012-04-06 11:24:09 UTC
fixed in web-main#964a6617c132
Comment 6 Marek Fukala 2012-04-06 13:53:05 UTC
*** Bug 210572 has been marked as a duplicate of this bug. ***
Comment 7 Quality Engineering 2012-04-07 10:09:40 UTC
Integrated into 'main-golden', will be available in build *201204070400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/964a6617c132
User: Marek Fukala <mfukala@netbeans.org>
Log: #210767 - StringIndexOutOfBoundsException: String index out of range: 803
Comment 8 host 2012-04-07 10:26:22 UTC
Created attachment 117974 [details]
stacktrace


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo