Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 210741 - org.netbeans.modules.j2ee.deployment.plugins.api.InstanceCreationException: No handlers for [C:\Program Files\glassfish-3.1.2\glassfish;C:\Program Files\glassfish-3.1.2\glassfish\domains\domain1]deplo
org.netbeans.modules.j2ee.deployment.plugins.api.InstanceCreationException: N...
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.2
All All
: P1 (vote)
: 7.2
Assigned To: TomasKraus
issues@serverplugins
EXCEPTIONS_REPORT
:
: 210885 210932 210967 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 05:44 UTC by sunbiz
Modified: 2012-04-19 07:11 UTC (History)
33 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (199.58 KB, text/plain)
2012-04-05 05:45 UTC, sunbiz
Details
stacktrace (199.58 KB, text/plain)
2012-04-05 06:53 UTC, williambacchi
Details
stacktrace (199.57 KB, text/plain)
2012-04-05 09:14 UTC, Vladimir Riha
Details
stacktrace (199.62 KB, text/plain)
2012-04-05 12:41 UTC, Jiri Skrivanek
Details
stacktrace (199.58 KB, text/plain)
2012-04-06 05:47 UTC, williambacchi
Details
stacktrace (199.51 KB, text/plain)
2012-04-06 10:56 UTC, gholmer
Details
stacktrace (199.59 KB, text/plain)
2012-04-06 14:41 UTC, Tomas Danek
Details
stacktrace (199.59 KB, text/plain)
2012-04-07 13:20 UTC, ytn01
Details
stacktrace (199.58 KB, text/plain)
2012-04-08 09:05 UTC, Maksim Khramov
Details
stacktrace (199.58 KB, text/plain)
2012-04-08 11:41 UTC, sunbiz
Details
stacktrace (199.58 KB, text/plain)
2012-04-09 12:26 UTC, everflux
Details
stacktrace (199.58 KB, text/plain)
2012-04-09 21:56 UTC, muellermi
Details
stacktrace (199.57 KB, text/plain)
2012-04-09 23:44 UTC, David Konecny
Details
stacktrace (199.58 KB, text/plain)
2012-04-10 07:47 UTC, Martin Fousek
Details
stacktrace (199.59 KB, text/plain)
2012-04-10 10:08 UTC, michal.owsiak
Details
stacktrace (199.59 KB, text/plain)
2012-04-10 13:17 UTC, Kenneth Ganfield
Details
stacktrace (199.58 KB, text/plain)
2012-04-10 18:29 UTC, viggonavarsete
Details
stacktrace (199.58 KB, text/plain)
2012-04-10 19:41 UTC, muellermi
Details
stacktrace (199.57 KB, text/plain)
2012-04-11 14:35 UTC, tim_sa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sunbiz 2012-04-05 05:44:52 UTC
Build: NetBeans IDE Dev (Build 201204040400)
VM: Java HotSpot(TM) 64-Bit Server VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b05
OS: Windows 7

User Comments:
jonathanvilalopez: Opening Netbeans with some projects loaded

zdenek.rod: I installed this version of nb development with previous build 201203210400.




Stacktrace: 
org.netbeans.modules.j2ee.deployment.plugins.api.InstanceCreationException: No handlers for [C:\Program Files\glassfish-3.1.2\glassfish;C:\Program Files\glassfish-3.1.2\glassfish\domains\domain1]deployer:gfv3ee6wc:localhost:4848
   at org.netbeans.modules.j2ee.deployment.impl.ServerRegistry.addInstanceImpl(ServerRegistry.java:533)
   at org.netbeans.modules.j2ee.deployment.impl.ServerRegistry.addInstanceImpl(ServerRegistry.java:529)
   at org.netbeans.modules.j2ee.deployment.impl.ServerRegistry.addInstance(ServerRegistry.java:383)
   at org.netbeans.modules.j2ee.deployment.plugins.api.InstanceProperties.createInstancePropertiesNonPersistent(InstanceProperties.java:296)
   at org.netbeans.modules.glassfish.javaee.JavaEEServerModuleFactory.createModule(JavaEEServerModuleFactory.java:123)
   at org.netbeans.modules.glassfish.common.GlassfishInstance.updateFactories(GlassfishInstance.java:201)
Comment 1 sunbiz 2012-04-05 05:45:03 UTC
Created attachment 117854 [details]
stacktrace
Comment 2 williambacchi 2012-04-05 06:53:29 UTC
Created attachment 117860 [details]
stacktrace

Opening a java web project after new installation
Comment 3 Vladimir Riha 2012-04-05 09:14:27 UTC
Created attachment 117870 [details]
stacktrace

during scanning at NetBeans start
Comment 4 Exceptions Reporter 2012-04-05 09:14:47 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=186661
Comment 5 Jiri Skrivanek 2012-04-05 12:41:27 UTC
Created attachment 117891 [details]
stacktrace

Restarted IDE with registered GlassFish.
Comment 6 williambacchi 2012-04-06 05:47:24 UTC
Created attachment 117921 [details]
stacktrace
Comment 7 gholmer 2012-04-06 10:56:24 UTC
Created attachment 117937 [details]
stacktrace

Exception dialog appeared during first start of build 201204050400 after installation.
Comment 8 Tomas Danek 2012-04-06 14:41:40 UTC
Created attachment 117950 [details]
stacktrace

creating webapp (activation of javaee modules)
Comment 9 Exceptions Reporter 2012-04-06 16:14:27 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=186661
Comment 10 ytn01 2012-04-07 13:20:28 UTC
Created attachment 117975 [details]
stacktrace

Installed a new nightly build of NetBeans JEE bundle.
Upon first and successive launch of the IDE, the error started to happen.
Just after the IDE launched & the error message appeard,... the IDE refused to quit normally,... had to kill it from the activity monitor.
Comment 11 Maksim Khramov 2012-04-08 09:05:30 UTC
Created attachment 117986 [details]
stacktrace
Comment 12 sunbiz 2012-04-08 11:41:27 UTC
Created attachment 117987 [details]
stacktrace
Comment 13 Exceptions Reporter 2012-04-08 11:50:23 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=186661
Comment 14 everflux 2012-04-09 12:26:23 UTC
Created attachment 118012 [details]
stacktrace

installed netbeans 7.2 dev "java ide" edition, importing plugins and settings from netbeans 7.1.1 "java ee" edition
Comment 15 Vince Kraemer 2012-04-09 16:48:36 UTC
Is this behavior related to http://hg.netbeans.org/web-main/rev/722614006deb

Were there other changes in the j2eeserver project or the server project that might have triggered this?

Please investigate.
Comment 16 muellermi 2012-04-09 21:56:26 UTC
Created attachment 118017 [details]
stacktrace

Starting this version of NB for the first time
Comment 17 David Konecny 2012-04-09 23:44:28 UTC
Created attachment 118026 [details]
stacktrace
Comment 18 Martin Fousek 2012-04-10 07:47:29 UTC
Created attachment 118032 [details]
stacktrace

1, Started IDE, registered GlassFish
-> since next IDE start still these exceptions happen
Comment 19 michal.owsiak 2012-04-10 10:08:32 UTC
Created attachment 118042 [details]
stacktrace

1. Install most recent Java release
2. Open NetBeans
3. Create simple JavaApplication

After project is created and scanning is complete exception is thrown
Comment 20 Kenneth Ganfield 2012-04-10 13:17:30 UTC
Created attachment 118058 [details]
stacktrace

started IDE with fresh userdir and then opened an existing Maven Java project
Comment 21 Petr Hejl 2012-04-10 15:26:26 UTC
This might be actually caused by #210932
Comment 22 viggonavarsete 2012-04-10 18:29:29 UTC
Created attachment 118082 [details]
stacktrace

Restart of Netbeans after crash.
Comment 23 muellermi 2012-04-10 19:41:28 UTC
Created attachment 118085 [details]
stacktrace

starting this version
Comment 24 David Konecny 2012-04-10 22:34:47 UTC
*** Bug 210885 has been marked as a duplicate of this bug. ***
Comment 25 David Konecny 2012-04-10 22:41:06 UTC
This is causing too much noise and whatever change caused it should be promptly reverted or hotfixed. Btw. looking at some IDE logs (eg. http://statistics.netbeans.org/exceptions/messageslog?id=572463 ) there is StackOverflowError so likely this issue and issue 210932 are about the same problem.
Comment 26 David Konecny 2012-04-11 00:24:31 UTC
This got to the state that I was not able to start IDE anymore. Reverting the fix from issue 205319 removes this exception. Done in web-main as:

changeset:   219455:1cb303917a69
parent:      218759:722614006deb
user:        David Konecny <dkonecny@netbeans.org>
date:        Wed Apr 11 12:08:01 2012 +1200
summary:     Backed out changeset 722614006deb
Comment 27 TomasKraus 2012-04-11 07:50:18 UTC
I was testing 205319 fix with JDK 1.6 and saw no problems. Will try with last 1.7 again to find what was causing troubles because I would like to keep those changes.
Comment 28 TomasKraus 2012-04-11 09:13:22 UTC
Tested again with

Product Version: NetBeans IDE Dev (Build 20120411-81608b13788d)
Java: 1.7.0_03; Java HotSpot(TM) 64-Bit Server VM 22.1-b02
System: Linux version 2.6.38-8-generic running on amd64; UTF-8; en_US (nb)
User directory: /home/kratz/.netbeans/dev
Cache directory: /home/kratz/.cache/netbeans/dev
+ 205319 diff applied

and everything works fine. 

This looks like some Win 64 + JDK 1.7 only related problem and explains why I hand no chance to see it before push.
Comment 29 viggonavarsete 2012-04-11 09:14:35 UTC
Tomas: As input, I run Ubuntu 11.10, so it's not only a windows problem...
Comment 30 Petr Hejl 2012-04-11 09:33:34 UTC
*** Bug 210932 has been marked as a duplicate of this bug. ***
Comment 31 TomasKraus 2012-04-11 11:45:11 UTC
Yes, I was finally able to reproduce it on Ubuntu too and I have new fix that will also resolve 205319. But I would like to check it with another guy in US before pushing it into repository.
Comment 32 tim_sa 2012-04-11 14:35:49 UTC
Created attachment 118140 [details]
stacktrace

created new maven project
Comment 33 TomasKraus 2012-04-11 14:44:55 UTC
changeset:   219483:fa7930503972
user:        Tomas Kraus <TomasKraus@netbeans.org>
date:        Wed Apr 11 16:31:57 2012 +0200
files:      
glassfish.common/src/org/netbeans/modules/glassfish/common/GlassfishInstanceProvider.java
description:
Bug# 205319 - IDE hangs after fresh install upon click to expand 'servers'
Bug# 210741 - InstanceCreationException caused by bug# 205319 fix.
Removed deadlock condition in
org.netbeans.modules.glassfish.common.GlassfishInstanceProvider
and org.netbeans.modules.j2ee.deployment.impl.ServerRegistry

This seems to not break anything.
Comment 34 TomasKraus 2012-04-11 15:24:26 UTC
One more change to avoid theoretical deadlock:

changeset:   219600:ae6cb02f6d83
user:        Tomas Kraus <TomasKraus@netbeans.org>
date:        Wed Apr 11 17:08:09 2012 +0200
files:       glassfish.common/src/org/netbeans/modules/glassfish/common/GlassfishInstanceProvider.java
description:
Bug# 205319 - IDE hangs after fresh install upon click to expand 'servers'
Bug# 210741 - InstanceCreationException caused by bug# 205319 fix.
Previos attempt to fix deadlock may not work so using more conservative fix.
Comment 35 Petr Hejl 2012-04-12 12:18:51 UTC
*** Bug 210967 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo