Bug 210574 - AssertionError at org.netbeans.modules.bugtracking.util.RepositoryComboRenderer.getListCellRendererComponent
AssertionError at org.netbeans.modules.bugtracking.util.RepositoryComboRender...
Status: RESOLVED INCOMPLETE
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
7.2
All All
: P3 (vote)
: TBD
Assigned To: Tomas Stupka
issues@connecteddeveloper
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 20:14 UTC by schkovich
Modified: 2012-04-11 14:05 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.58 KB, text/plain)
2012-04-02 20:14 UTC, schkovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-04-02 20:14:51 UTC
Build: NetBeans IDE Dev (Build 201204021038)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: Reporting New Issue right after defining JIRA connector




Stacktrace: 
java.lang.AssertionError
   at org.netbeans.modules.bugtracking.util.RepositoryComboRenderer.getListCellRendererComponent(RepositoryComboRenderer.java:87)
   at javax.swing.plaf.basic.BasicComboBoxUI.getDisplaySize(BasicComboBoxUI.java:1348)
   at javax.swing.plaf.basic.BasicComboBoxUI.getMinimumSize(BasicComboBoxUI.java:922)
   at javax.swing.plaf.basic.BasicComboBoxUI.getPreferredSize(BasicComboBoxUI.java:911)
   at javax.swing.JComponent.getPreferredSize(JComponent.java:1660)
   at javax.swing.GroupLayout$ComponentSpring.calculateNonlinkedPreferredSize(GroupLayout.java:3019)
Comment 1 schkovich 2012-04-02 20:14:54 UTC
Created attachment 117691 [details]
stacktrace
Comment 2 Tomas Stupka 2012-04-11 10:19:21 UTC
can't reproduce and hard to say what could be the cause for the problem.
added more diagnostic info in core-main #49843a47ef3c, lets deal with it when we will know more
Comment 3 schkovich 2012-04-11 11:14:16 UTC
(In reply to comment #2)
> can't reproduce and hard to say what could be the cause for the problem.
> added more diagnostic info in core-main #49843a47ef3c, lets deal with it when
> we will know more

OK. Once available I will give it a try. However, please not that JIRA plugin is essentially completely unusable on Linux. :(
Comment 4 Tomas Stupka 2012-04-11 12:05:28 UTC
> OK. Once available I will give it a try. However, please not that JIRA plugin
> is essentially completely unusable on Linux. :(
how exactly?
Comment 5 schkovich 2012-04-11 14:05:05 UTC
(In reply to comment #4)
> > OK. Once available I will give it a try. However, please not that JIRA plugin
> > is essentially completely unusable on Linux. :(
> how exactly?
See #211013 (error will be thrown over and over again, rendering rows, cels, and I had to shutdown IDE), #210043, #211011 (that was wicked: somehow jira atlassian connector appeared on the list of available plugins).

However, I am going to modify statement: I can now search issues on commit and attach issue to commit message.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo