Bug 210502 - AssertionError: profile
AssertionError: profile
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Ide
7.2
All All
: P1 (vote)
: 7.2
Assigned To: J Bachorik
issues@profiler
EXCEPTIONS_REPORT
:
: 210573 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 07:20 UTC by Martin Fousek
Modified: 2012-04-06 10:08 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.31 KB, text/plain)
2012-04-02 07:20 UTC, Martin Fousek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Fousek 2012-04-02 07:20:54 UTC
Build: NetBeans IDE Dev (Build 20120402-f78bb3b9dcd4)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.1-b02, Java(TM) SE Runtime Environment, 1.6.0_26-b03
OS: Linux

User Comments:
marfous: created new php project




Stacktrace: 
java.lang.AssertionError: profile
   at org.netbeans.modules.php.project.PhpActionProvider.getCommand(PhpActionProvider.java:146)
   at org.netbeans.modules.php.project.PhpActionProvider.isActionEnabled(PhpActionProvider.java:141)
   at org.netbeans.modules.profiler.nbimpl.actions.ProjectSensitivePerformer.enable(ProjectSensitivePerformer.java:72)
   at org.netbeans.modules.project.ui.actions.MainProjectAction$1.run(MainProjectAction.java:175)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452)
   at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032)
Comment 1 Martin Fousek 2012-04-02 07:20:58 UTC
Created attachment 117624 [details]
stacktrace
Comment 2 Tomas Mysik 2012-04-02 07:33:38 UTC
Caused by some profiler changes? Please evaluate, thanks.

P2 since my IDE did not start.

Thanks.
Comment 3 J Bachorik 2012-04-02 08:13:04 UTC
Fixing in http://hg.netbeans.org/profiler-main/rev/4c000bdeb20d
Comment 4 Tomas Mysik 2012-04-02 08:23:41 UTC
(In reply to comment #3)
> Fixing in http://hg.netbeans.org/profiler-main/rev/4c000bdeb20d

Will this change be propagated to main-silver automatically?
Comment 5 Tomas Hurka 2012-04-02 12:08:19 UTC
The fix is in main-silver: http://hg.netbeans.org/main-silver/rev/4c000bdeb20d
Comment 6 Tomas Mysik 2012-04-02 12:47:58 UTC
Thanks a lot!
Comment 7 Tomas Mysik 2012-04-02 15:09:58 UTC
Still not fixed, sorry.

java.lang.AssertionError: profile
        at org.netbeans.modules.php.project.PhpActionProvider.getCommand(PhpActionProvider.java:146)
        at org.netbeans.modules.php.project.PhpActionProvider.isActionEnabled(PhpActionProvider.java:141)
        at org.netbeans.modules.profiler.nbimpl.actions.ProjectSensitivePerformer.enable(ProjectSensitivePerformer.java:77)
        at org.netbeans.modules.project.ui.actions.MainProjectAction$1.run(MainProjectAction.java:175)
        at org.netbeans.modules.project.ui.actions.MainProjectAction.refreshView(MainProjectAction.java:200)
        at org.netbeans.modules.project.ui.actions.MainProjectAction.refresh(MainProjectAction.java:218)
        at org.netbeans.modules.project.ui.actions.LookupSensitiveAction.doRefresh(LookupSensitiveAction.java:193)
        at org.netbeans.modules.project.ui.actions.LookupSensitiveAction.isEnabled(LookupSensitiveAction.java:136)
Comment 8 Tomas Mysik 2012-04-02 15:28:23 UTC
Hotfixed in PHP.

http://hg.netbeans.org/web-main/rev/7e4bcc3c8f95
Comment 9 Tomas Mysik 2012-04-02 15:35:44 UTC
BTW maybe you should check ActionProvider.getSupportedActions() first? But really not sure since I have no idea how ProjectProfilingSupport class gets to PHP project.

Thanks.
Comment 10 J Bachorik 2012-04-03 07:39:10 UTC
Checking the supported actions first. Also fixing still wrong order ...
http://hg.netbeans.org/profiler-main/rev/2a4102ecc126
Comment 11 Tomas Mysik 2012-04-03 08:00:49 UTC
*** Bug 210573 has been marked as a duplicate of this bug. ***
Comment 12 Quality Engineering 2012-04-03 11:15:34 UTC
Integrated into 'main-golden', will be available in build *201204030400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4c000bdeb20d
User: Jaroslav Bachorik <yardus@netbeans.org>
Log: #210502: Changing the order of "action enabled" checks in order not to bother projects without profiling support
Comment 13 Quality Engineering 2012-04-06 10:08:43 UTC
Integrated into 'main-golden', will be available in build *201204060400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/2a4102ecc126
User: Jaroslav Bachorik <yardus@netbeans.org>
Log: #210502: Utilizing ActionProvider.getSupportedActions() to decide whether to ask the provider about an action enablement


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo