Bug 210492 - LowPerformance took 7126 ms.
LowPerformance took 7126 ms.
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
7.2
All All
: P3 (vote)
: 7.2
Assigned To: David Konecny
issues@javaee
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-01 18:32 UTC by genomega
Modified: 2012-04-05 09:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (230.52 KB, application/nps)
2012-04-01 18:32 UTC, genomega
Details

Note You need to log in before you can comment on or make changes to this bug.
Description genomega 2012-04-01 18:32:49 UTC
This bug was originally marked as duplicate of bug 176835, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201203230400)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
genomega: Adding ICEfaces to Framework ..



Maximum slowness yet reported was 7126 ms, average is 7126
Comment 1 genomega 2012-04-01 18:32:59 UTC
Created attachment 117608 [details]
nps snapshot
Comment 2 Martin Fousek 2012-04-02 04:44:15 UTC
According to user's comment looks like JSF related for now.
Comment 3 Martin Fousek 2012-04-02 09:32:21 UTC
Reassigning to web.project after deeper evaluation...

My opinion is that at least time-consuming content of WebProjectProperties#save() method should be called in its (RP) thread - not sent into AWT EDT. Actually code which makes troubles in this issue was added by me, but according to already existing usage for project's extending.

In other words, both solution WebProjectProperties:530-558 doesn't look 100% correct to me since it freezes UI by project customizer saving and also can cause these LowPerformance troubles (in extender's saving as well as extending). BTW, the real impact of this issue is quite low since the progress dialog appeared (although frozen).

David what is your opinion? In any case feel free to reassign it back to me if you think that should be fixed on my side or by me. Thanks.
Comment 4 David Konecny 2012-04-04 03:43:40 UTC
Saving Project Properties runs intentionally outside of AWT thread. Posting installation of frameworks and/or jsf suites back to AWT thread is wrong and goes against what we are trying to achieve here. I'm going to fix this by removal of "SwingUtilities.invokeLater". It was introduced as fix of issue 120108 but it does not sounds right - I wonder what was real cause of the deadlock and whether it was fixable some other way. Unfortunately GWT4NB is not available for 7.2Dev so I cannot retest. But if the deadlock is limited only to GWT4NB then it must be doing something incorrect.

What are your thoughts on this fix Martin?

ee24b5f7bba7
Comment 5 Martin Fousek 2012-04-04 05:08:20 UTC
Definitely agree with all of your words. According to Project UI APIs work flow runs these jobs outside AWT EDT looks to me like the only correct way for now.

Thanks David.
Comment 6 Quality Engineering 2012-04-05 09:41:55 UTC
Integrated into 'main-golden', will be available in build *201204050400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/ee24b5f7bba7
User: David Konecny <dkonecny@netbeans.org>
Log: #210492 - LowPerformance took 7126 ms


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo