Bug 210438 - SNAPSHOT version is deprecated
SNAPSHOT version is deprecated
Status: RESOLVED FIXED
Product: www
Classification: Unclassified
Component: Builds & Repositories
7.2
All All
: P2 (vote)
: 7.4
Assigned To: pgebauer
nbre
: NO72, NO73
Depends on:
Blocks: 228747
  Show dependency treegraph
 
Reported: 2012-03-30 13:51 UTC by Milos Kleint
Modified: 2013-06-06 13:31 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milos Kleint 2012-03-30 13:51:52 UTC
the netbeans snapshot repository contains just artifacts with SNAPSHOT version, however the currently supported pattern is only x-SNAPSHOT, eg. 1.0-SNAPSHOT, RELEASE72-SNAPSHOT

if you use SNAPSHOT in your project maven will warn you, it doesn't seem to warn about using it in dependencies though.


see 
http://www.mail-archive.com/dev@maven.apache.org/msg86634.html
http://jira.codehaus.org/browse/MNG-4957

this bugfix of mine is also related:
http://hg.netbeans.org/core-main/rev/cad52f79e17d

In general this issue is about changing the versioning from SNAPSHOT to something else in the snapshot repository and update the maven.apisupport codebase (the version selection combo at least)
Comment 1 Jesse Glick 2012-03-30 22:14:01 UTC
Has to be fixed in the repository generation script before apisupport.maven can do anything.

What version name do you suggest? dev-SNAPSHOT perhaps? Any sorting considerations relative to RELEASEnn?
Comment 2 Milos Kleint 2012-04-02 06:11:40 UTC
the "maven style" versioning is RELEASE71-SNAPSHOT, then RELEASE-71, then RELEASE72-SNAPSHOT..

I guess dev-SNAPSHOT as a generic name for non-release artifacts is fine as well. Given that we will never unintentionally release the DEV version. As a result it's less work for us to remember to do on  every release..

we don't use a numbering scheme, so I believe sorting doesn't apply to us.
Comment 3 Jesse Glick 2012-04-02 14:32:47 UTC
(In reply to comment #2)
> the "maven style" versioning is RELEASE71-SNAPSHOT

Unfortunately this would be trickier to use from maven.apisupport; prefer to have a predetermined version label.
Comment 4 skygo 2012-04-11 13:37:09 UTC
Hi, this issue allows me to wake up mine :p #207852.

I look at many places but I did not find pointer for "maven framework for netbeans". 

1)
I am not aware why RELEASEnn scheme was choosen but why not having:
7.1.1 as a version instead RELEASE711
using number means release.
RELEASEnn scheme consider 3 digits version superior as 2 digits (i.e. R711 > R72) (Sorting as a bonus)

2)
I don't know when new version number of netbeans is choosen but last dev SNAPSHOT may be
 7.2-SNAPSHOT for a new release.
 allowing a per bugfix branch 7.1.2-SNAPSHOT 

3)
I don't have the point using predetermined scheme versus not.
If artifact version become comparable it may be possible to seek last snapshot from the repository and propose it.

If maven.apisupport generate version using properties it may facilitate works for user to "migrate" to any scheme.
<netbeans.version>RELEASE711</netbeans.version>
<dependency>
  <groupId>org.netbeans.api</groupId>
  <artifactId>org-netbeans-modules-settings</artifactId>
  <version>${netbeans.version}</version>
</dependency>
Comment 5 Jesse Glick 2012-04-11 15:15:31 UTC
skygo - these comments are out of scope here. For current purposes we need a single fixed string for the snapshot repository, and "SNAPSHOT" is just not allowed by Maven 3, so we need some other fixed string ending in "-SNAPSHOT". That is all.
Comment 6 skygo 2012-04-12 09:34:33 UTC
Sorry for out of scope.

To make new naming more consistent I suggest having an upcased whatever string before the -SNAPSHOT. 
( DEV-SNAPSHOT )

may also be NEXTRELEASE-SNAPSHOT (Next Release is a term used in wiki page on netbeans.org)
Comment 7 pgebauer 2012-11-09 16:14:55 UTC
The issue isn't related to any NetBeans release but to the daily trunk build.
Comment 8 pgebauer 2012-11-14 09:59:23 UTC
The daily build maven repository with the string dev-SNAPSHOT is available internally for testing
Comment 9 Milos Kleint 2013-04-30 12:53:23 UTC
issue 228747 depends on this.

I would suggest the transition plan should include migrating to http://bits.netbeans.org/nexus/content/repositories/snapshots/ as the official URL when changing to dev-SNAPSHOT. and keeping the old snapshot repository around for a while with the old SNAPSHOT version but not upgrading it.

once the new snapshot repository is created, I'll update the locations in maven archetypes and code we have..

would be nice to have before 7.4 beta, thanks
Comment 10 pgebauer 2013-06-04 20:12:19 UTC
I have generated a repository dev-SNAPSHOT into the URL http://bits.netbeans.org/nexus/content/repositories/snapshots/ . Could you please do a sanity check?
Comment 11 Jesse Glick 2013-06-04 21:33:18 UTC
Seems OK to me. I had a problem building an NBM app against this repo—failure to find org.netbeans.modules:org-netbeans-modules-apisupport-harness in the nbm-application module—but I think it was an issue with a *-mirror.
Comment 12 skygo 2013-06-05 17:12:51 UTC
Nice :). 
Tested on NBM with lots of clusters + integration test. (api ide java platform ...) worked like a charm. No checksum issue.

Metadata seems also ok. (AFAIK only last build must be in snapshot metadata, that was the case for the 4th of june and 5th of june) 

BTW if you need specific check. Let me know.

Thanks for the evolution.
Comment 13 Milos Kleint 2013-06-06 07:50:05 UTC
appears to be working for me fine for the basic scenarios and for issue 228747

(In reply to comment #11)
> Seems OK to me. I had a problem building an NBM app against this repo—failure
> to find org.netbeans.modules:org-netbeans-modules-apisupport-harness in the
> nbm-application module—but I think it was an issue with a *-mirror.

are you using 3.8/3.9 nbm maven plugin? issue 228747 fixes the problem for 3.10, but I assume for 3.8/3.9 the new or old format doesn't matter.
Comment 14 pgebauer 2013-06-06 08:08:21 UTC
Currently NetBeans nightly builds generate data two maven repositories:

- http://bits.netbeans.org/trunk/maven-snapshot/ -> the old fashion repo with SNAPSHOT version

- http://bits.netbeans.org/nexus/content/repositories/snapshots/ -> the repo with dev-SNAPSHOT version

Please, let me know once I can stop data generation for the old one.
Comment 15 Jesse Glick 2013-06-06 13:31:28 UTC
(In reply to comment #13)
> are you using 3.8/3.9 nbm maven plugin?

3.9


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo