Bug 210415 - NullPointerException at org.netbeans.modules.editor.lib2.view.DocumentView.updateStartEndOffsets
NullPointerException at org.netbeans.modules.editor.lib2.view.DocumentView.up...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Miloslav Metelka
issues@editor
EXCEPTIONS_REPORT
:
: 211031 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 10:20 UTC by aldobrucale
Modified: 2012-05-29 05:43 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.11 KB, text/plain)
2012-03-30 10:21 UTC, aldobrucale
Details
stacktrace (2.11 KB, text/plain)
2012-04-04 10:44 UTC, stefan79
Details
stacktrace (2.11 KB, text/plain)
2012-04-24 03:05 UTC, Jesse Glick
Details
stacktrace (2.11 KB, text/plain)
2012-04-25 23:23 UTC, schkovich
Details
stacktrace (2.11 KB, text/plain)
2012-04-27 13:17 UTC, Petr Jiricka
Details
stacktrace (2.11 KB, text/plain)
2012-05-27 22:32 UTC, MackSix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aldobrucale 2012-03-30 10:20:59 UTC
This bug was originally marked as duplicate of bug 208524, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201203280401)
VM: Java HotSpot(TM) Client VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b04
OS: Linux

User Comments:
aldobrucale: Refresh Diff window after external changes

GUEST: -trying to view local history of a file.




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.editor.lib2.view.DocumentView.updateStartEndOffsets(DocumentView.java:657)
   at org.netbeans.modules.editor.lib2.view.DocumentView.setParent(DocumentView.java:622)
   at javax.swing.plaf.basic.BasicTextUI$RootView.setView(BasicTextUI.java:1330)
   at javax.swing.plaf.basic.BasicTextUI.setView(BasicTextUI.java:695)
   at org.netbeans.editor.BaseTextUI.modelChanged(BaseTextUI.java:179)
   at javax.swing.plaf.basic.BasicTextUI$UpdateHandler.propertyChange(BasicTextUI.java:1788)
Comment 1 aldobrucale 2012-03-30 10:21:05 UTC
Created attachment 117534 [details]
stacktrace
Comment 2 stefan79 2012-04-04 10:44:16 UTC
Created attachment 117801 [details]
stacktrace

Exception occured, whe I make CVS-Diff at a Java-File.
Comment 3 Jesse Glick 2012-04-24 03:05:25 UTC
Created attachment 118669 [details]
stacktrace

Diff view in local history tab.
Comment 4 Exceptions Reporter 2012-04-24 03:05:41 UTC
This bug already has 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=186466
Comment 5 Marian Mirilovic 2012-04-25 11:45:39 UTC
*** Bug 211031 has been marked as a duplicate of this bug. ***
Comment 6 schkovich 2012-04-25 23:23:27 UTC
Created attachment 118771 [details]
stacktrace

switched from source to history and seleced desired local version
Comment 7 Petr Jiricka 2012-04-27 13:17:26 UTC
Created attachment 118875 [details]
stacktrace

Exploring revisions in the local history tab in the editor (for Java file).
Comment 8 MackSix 2012-05-27 22:32:44 UTC
Created attachment 119922 [details]
stacktrace

Using navigation arrows in "History".
Comment 9 Miloslav Metelka 2012-05-28 09:39:22 UTC
http://hg.netbeans.org/jet-main/rev/5996fb21b80e
Comment 10 Quality Engineering 2012-05-29 05:43:20 UTC
Integrated into 'main-golden', will be available in build *201205290002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5996fb21b80e
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #210415 - NullPointerException at org.netbeans.modules.editor.lib2.view.DocumentView.updateStartEndOffsets.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo