Bug 21025 - Monitor does not record transactions on Windows
Monitor does not record transactions on Windows
Status: CLOSED WORKSFORME
Product: serverplugins
Classification: Unclassified
Component: Tomcat
-FFJ-
PC Windows ME/2000
: P1 (vote)
: TBD
Assigned To: Milan Kuchtiak
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-28 19:36 UTC by Jason Rush
Modified: 2002-07-19 15:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Rush 2002-02-28 19:36:20 UTC
In the orion_ea branch, on Windows platforms, the HTTP Monitor is not recording
any data on requests made on the internal instance of Tomcat.  Examining the
tomcat server.xml file shows that the MonitorValve is declared properly for the
web module, so I do not know the root cause of the problem.
Comment 1 Jason Rush 2002-02-28 22:28:42 UTC
It turns out that the Tomcat plug-in is not adding the Monitor filter
to the web.xml file properly when the web module is executed.
Comment 2 Milan Kuchtiak 2002-03-01 08:07:20 UTC
I cannot reproduce this bug :

Please send me the :

- default web.xml file (netbeans_home/tomcat401/conf directory)
- server.xml file
- content of netbeans_home/tomcat401/lib directory
- content of netbeans_home/tomcat401/server/lib directory
- what is the property IDE Integration Mode set for ? 

Thanks
Comment 3 Damian Frach 2002-03-01 08:26:38 UTC
some comments from mailing list

-----------------------------------------------
Team--

Just FYI, this is a critical showstopper as I am currently unable to 
run Monitor 
on Windows.  It works fine on Solaris, but is not recording any data 
on Windows.


Thanks,
Jason

-----------------------------------------------------

Jason and I just looked at this, and it turns out that the Plugin 
does 
not declare the MonitorFilter into conf/web.xml anymore. This is a
problem with the Tomcat plugin. Jason will reassign the issue. 

Ana

------------------------------------------------------

Actually, it turns out that this is a Tomcat plug-in bug.  The 
Monitor filter is 
not being declared properly in the web.xml file on Windows.  I've 
changed this 
bug to category 'tomcatint' and re-assigned to Milan.


Thanks,
Jason





Comment 4 Damian Frach 2002-03-01 08:49:04 UTC
works for me too: 

win 2000; jdk 1.4; Forte for Java, EE v. 4.0-EA (Build 020227)

- convert FS to web module
- create a JSP
- open a monitor
- execute the JSP
- see the JSP in the browser
- open a monitor window again, because the IDE shows "running" tab

- all is OK; there is a HTTP request in the monitor window
Comment 5 Jason Rush 2002-03-01 09:16:21 UTC
I've tried it again and it seems to be working fine.  I have no idea 
why it was not working previously.  Since this is not a bug, I am 
closing it.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo