Bug 210236 - IllegalArgumentException: No parser for mime type: text/x-java
IllegalArgumentException: No parser for mime type: text/x-java
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Settings
7.2
All All
: P2 (vote)
: 7.2
Assigned To: David Strupl
issues@editor
EXCEPTIONS_REPORT
: ERGONOMICS
: 208690 210744 216591 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-28 06:29 UTC by stefan79
Modified: 2012-10-08 16:34 UTC (History)
14 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.23 KB, text/plain)
2012-03-28 06:29 UTC, stefan79
Details
stacktrace (1.23 KB, text/plain)
2012-03-28 09:11 UTC, aldobrucale
Details
stacktrace (1.23 KB, text/plain)
2012-03-29 08:41 UTC, aldobrucale
Details
stacktrace (1.23 KB, text/plain)
2012-03-29 10:44 UTC, ttokoly
Details
stacktrace (1.23 KB, text/plain)
2012-03-30 15:41 UTC, host
Details
stacktrace (1.23 KB, text/plain)
2012-04-01 08:17 UTC, sunbiz
Details
stacktrace (1.23 KB, text/plain)
2012-04-02 07:47 UTC, williambacchi
Details
stacktrace (1.23 KB, text/plain)
2012-04-03 08:32 UTC, aldobrucale
Details
stacktrace (1.23 KB, text/plain)
2012-04-03 12:47 UTC, ttokoly
Details
stacktrace (1.23 KB, text/plain)
2012-04-11 18:29 UTC, williambacchi
Details
stacktrace (1.23 KB, text/plain)
2012-04-13 12:56 UTC, asenk
Details
stacktrace (1.23 KB, text/plain)
2012-04-17 14:59 UTC, Tomas Danek
Details
patch1 (1.95 KB, patch)
2012-04-20 17:52 UTC, David Strupl
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description stefan79 2012-03-28 06:29:49 UTC
Build: NetBeans IDE Dev (Build 201203271056)
VM: Java HotSpot(TM) 64-Bit Server VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b05
OS: Windows 7

User Comments:
GUEST: While executing a JavaFX code using a REST API (which failed leaving some java.exe process running). Then on restarting Netbeans(and killing the java.exe process), it fails to start completely with the above error.

GUEST: java com erro no netbens

GUEST: starting ide

stefan79: Started NetBeans after new Installation

GUEST: starting netbeans ide




Stacktrace: 
java.lang.IllegalArgumentException: No parser for mime type: text/x-java
   at org.netbeans.modules.parsing.api.ParserManager.findParser(ParserManager.java:394)
   at org.netbeans.modules.parsing.api.ParserManager.parse(ParserManager.java:330)
   at org.netbeans.api.java.source.JavaSource.runUserActionTaskImpl(JavaSource.java:416)
   at org.netbeans.api.java.source.JavaSource.runUserActionTask(JavaSource.java:408)
   at org.netbeans.api.java.source.ScanUtils.postJavaTask(ScanUtils.java:359)
   at org.netbeans.api.java.source.ScanUtils.postUserActionTask(ScanUtils.java:121)
Comment 1 stefan79 2012-03-28 06:29:54 UTC
Created attachment 117370 [details]
stacktrace
Comment 2 aldobrucale 2012-03-28 09:11:19 UTC
Created attachment 117381 [details]
stacktrace

starting netbeans, importing from previous version (the exception appeared two more times while I was writing this)
Comment 3 Exceptions Reporter 2012-03-28 09:11:35 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=148306
Comment 4 Tomas Zezula 2012-03-28 09:51:26 UTC
The JavaParserFactory is registered by java.source module.
The java.j2seproject depends on it and it's enabled as seen from stack trace (JavaSource.runUserActionTask) but the JavaParserFactory is not found in the mime lookup.
Probably all resources cache is broken.
Comment 5 aldobrucale 2012-03-29 08:41:21 UTC
Created attachment 117450 [details]
stacktrace

nb start
Comment 6 ttokoly 2012-03-29 10:44:21 UTC
Created attachment 117460 [details]
stacktrace

Just opened a project from clean start.
Project default from refactoring test specification: http://wiki.netbeans.org/wiki/images/2/2d/Default_TS_60_Refactoring.zip
Comment 7 host 2012-03-30 15:41:21 UTC
Created attachment 117563 [details]
stacktrace
Comment 8 sunbiz 2012-04-01 08:17:20 UTC
Created attachment 117600 [details]
stacktrace

Opening JavaSE project
Comment 9 williambacchi 2012-04-02 07:47:19 UTC
Created attachment 117627 [details]
stacktrace
Comment 10 aldobrucale 2012-04-03 08:32:18 UTC
Created attachment 117713 [details]
stacktrace

starting nb
Comment 11 ttokoly 2012-04-03 12:47:16 UTC
Created attachment 117736 [details]
stacktrace

Only open a project (project default from refactoring test specification) from clean start of IDE and this error shows up.
Comment 12 Exceptions Reporter 2012-04-03 12:47:22 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=148306
Comment 13 williambacchi 2012-04-11 18:29:24 UTC
Created attachment 118157 [details]
stacktrace

opening a project with reference problems
Comment 14 asenk 2012-04-13 12:56:25 UTC
Created attachment 118240 [details]
stacktrace

1.Start IDE full distro - fresh install, clean user dir
2.Create J2SE project
Comment 15 Jan Lahoda 2012-04-15 17:08:08 UTC
*** Bug 210744 has been marked as a duplicate of this bug. ***
Comment 16 Jan Lahoda 2012-04-15 17:08:38 UTC
*** Bug 208690 has been marked as a duplicate of this bug. ***
Comment 17 Tomas Danek 2012-04-17 14:59:24 UTC
Created attachment 118417 [details]
stacktrace

for some reason, ergonomics tried to activate javaME during opening java file in j2se project. Do not know why.
Comment 18 David Strupl 2012-04-20 12:38:41 UTC
I will try to have a look.
Comment 19 David Strupl 2012-04-20 17:52:00 UTC
Created attachment 118576 [details]
patch1
Comment 20 David Strupl 2012-04-20 17:53:44 UTC
Tomasi, can you please review the patch? I know you didn't want to fix it like this but I was not able to come up with anything better. Mime lookup can be slow to update and you are asking too soon ...
Comment 21 Exceptions Reporter 2012-04-22 18:47:28 UTC
This bug already has 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=148306
Comment 22 David Strupl 2012-04-23 14:56:57 UTC
As per Tomas: the fix should be refined and mime lookup should return a future when it is rebuilding itself (instead of blindly waiting in parsing API).
Comment 23 Tomas Zezula 2012-04-23 14:58:05 UTC
Yes.
Thanks Davide.
Comment 24 David Strupl 2012-04-25 12:53:26 UTC
The fix is different from the original patch. I am trying to make the mime lookup rebuild synchronous:

http://hg.netbeans.org/jet-main/rev/37ecf414494a

Let's see whether the problems will be gone after this, I plan still to integrate a test ....
Comment 25 Milutin Kristofic 2012-10-08 16:34:54 UTC
*** Bug 216591 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo