Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 210088 - Allow changing encoding of properties files to other than ISO 8859-1
Allow changing encoding of properties files to other than ISO 8859-1
Status: RESOLVED DUPLICATE of bug 75906
Product: utilities
Classification: Unclassified
Component: Properties
7.1
PC Windows 7
: P2 (vote)
: TBD
Assigned To: Jan Peska
issues@utilities
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-26 10:45 UTC by akobberup
Modified: 2012-04-03 07:55 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description akobberup 2012-03-26 10:45:36 UTC
It would be extremely useful to be able to change the file encoding for .properties files, even more so on a 'per-project' basis, as some frameworks require that the .properties files has for example UTF-8 encoding.

My example is that i am developing a large GWT application, and all .properties files in this MUST be UTF-8 encoded.

While I know that this is not what is stated in the Properties, I also realize that it is a lost cause to change this fact.
Therefore i currently have to use another editor than NetBeans for maintaining my properties files for this project.

I believe that i will be a great enhancement for the editor, if it could detect the encoding of the file, and don't change this event if not set to ISO 8859-1 when updating the file.
Also it should be a project option what format should be used when creating new .properties filed (so that for normal Java projects, it will be ISO 8859-1), so that you can change it when working on, for example a GWT project.
Comment 1 Jan Peska 2012-04-03 07:55:34 UTC

*** This bug has been marked as a duplicate of bug 75906 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo