Bug 210058 - NullPointerException at org.netbeans.modules.subversion.ui.commit.CommitAction$5.getCopiedFromFile
NullPointerException at org.netbeans.modules.subversion.ui.commit.CommitActio...
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.2
All All
: P2 (vote)
: 7.2
Assigned To: Ondrej Vrabec
issues@versioncontrol
EXCEPTIONS_REPORT
:
: 210317 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 18:44 UTC by schkovich
Modified: 2012-04-09 18:59 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.22 KB, text/plain)
2012-03-25 18:44 UTC, schkovich
Details
stacktrace (4.22 KB, text/plain)
2012-03-29 12:59 UTC, schkovich
Details
stacktrace (2.29 KB, text/plain)
2012-04-02 10:23 UTC, mrpc
Details
stacktrace (2.28 KB, text/plain)
2012-04-02 12:32 UTC, aws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-03-25 18:44:24 UTC
Build: NetBeans IDE Dev (Build 201203250401)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: Pressing button commit all

gilbertoca: Project->Subversion->show changes
After that appers somes changed files, then click commit all




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.subversion.ui.commit.CommitAction$5.getCopiedFromFile(CommitAction.java:496)
   at org.netbeans.modules.subversion.ui.commit.CommitAction$5.addDeletedFiles(CommitAction.java:476)
   at org.netbeans.modules.subversion.ui.commit.CommitAction$5.perform(CommitAction.java:447)
   at org.netbeans.modules.subversion.client.SvnProgressSupport.performIntern(SvnProgressSupport.java:109)
   at org.netbeans.modules.subversion.client.SvnProgressSupport.run(SvnProgressSupport.java:102)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452)
Comment 1 schkovich 2012-03-25 18:44:26 UTC
Created attachment 117212 [details]
stacktrace
Comment 2 Ondrej Vrabec 2012-03-28 14:06:57 UTC
fix: http://hg.netbeans.org/core-main/rev/2228729eb96f
Comment 3 Ondrej Vrabec 2012-03-28 19:15:04 UTC
*** Bug 210317 has been marked as a duplicate of this bug. ***
Comment 4 schkovich 2012-03-29 12:59:20 UTC
Created attachment 117471 [details]
stacktrace

Commit all. This one looked like fixed. :( Regression?
Comment 5 mrpc 2012-04-02 10:23:22 UTC
Created attachment 117645 [details]
stacktrace

Tried to commit a subversion project. The exception appeared after the scan for changes.
Comment 6 aws 2012-04-02 12:32:19 UTC
Created attachment 117653 [details]
stacktrace
Comment 7 Exceptions Reporter 2012-04-09 18:59:27 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=186150


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo