Bug 209915 - Projects do not run as WebStart on Mac with JDK 7u4
Projects do not run as WebStart on Mac with JDK 7u4
Status: RESOLVED WONTFIX
Product: javafx
Classification: Unclassified
Component: Deployment
7.1.1
Macintosh Mac OS X
: P1 (vote)
: TBD
Assigned To: Petr Somol
issues@javafx
: RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 10:34 UTC by Petr Somol
Modified: 2012-03-24 11:05 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Somol 2012-03-22 10:34:28 UTC
On Mac with JDK 7u4 it is not possible to run a Java/JavaFX project using WebStart technology. Run fails because webstart executable is not found.
Comment 1 Petr Somol 2012-03-22 10:52:18 UTC
The issue is caused by a problem outside NetBeans. JDK 7u4 indeed does not support WebStart technology. However, WebStart support should appear in next upcoming Mac JDK 7 updates.

If a NetBeans Java/JavaFX project is set to run as WebStart on Mac JDK 7u4 in NetBeans 7.1 or 7.1.1, the run operation simply fails. NetBeans 7.1.2 and 7.2 on Mac JDK 7u4 additionally write out a message explaining that WebStart is not supported on Mac JDK 7u4. The build process is not affected and produces WebStart related artifacts (JNLP file) as expected.
Comment 2 Petr Somol 2012-03-22 13:19:37 UTC
Remark: MacJDK7u4 detection and warning has been added to FX build scripts as part of issue 208798:
http://netbeans.org/bugzilla/show_bug.cgi?id=208798
and to SE WebStart script in changeset:
http://hg.netbeans.org/jet-main/rev/bbe09d7619cc
Comment 3 Quality Engineering 2012-03-24 11:05:22 UTC
Integrated into 'main-golden', will be available in build *201203240400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/bbe09d7619cc
User: Petr Somol <psomol@netbeans.org>
Log: #209915 added warning to SE WebStart scripts about missing support in MacJDK7u4


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo