Bug 209670 - NullPointerException at javax.swing.BoxLayout.preferredLayoutSize
NullPointerException at javax.swing.BoxLayout.preferredLayoutSize
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Tomas Stupka
issues@connecteddeveloper
EXCEPTIONS_REPORT
:
: 210043 210044 211013 224348 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 15:32 UTC by David Strupl
Modified: 2013-01-02 16:59 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.07 KB, text/plain)
2012-03-16 15:32 UTC, David Strupl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Strupl 2012-03-16 15:32:50 UTC
Build: NetBeans IDE Dev (Build 201203150400)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.4-b02-402, Java(TM) SE Runtime Environment, 1.6.0_29-b11-402-11D50b
OS: Mac OS X

Stacktrace: 
java.lang.NullPointerException
   at javax.swing.BoxLayout.preferredLayoutSize(BoxLayout.java:282)
   at java.awt.Container.preferredSize(Container.java:1599)
   at java.awt.Container.getPreferredSize(Container.java:1584)
   at javax.swing.JComponent.getPreferredSize(JComponent.java:1636)
   at org.netbeans.modules.bugtracking.ui.query.QueryTopComponentScrollPaneLayout.layoutContainer(QueryTopComponentScrollPaneLayout.java:234)
   at java.awt.Container.layout(Container.java:1421)
Comment 1 David Strupl 2012-03-16 15:32:51 UTC
Created attachment 116806 [details]
stacktrace
Comment 2 Tomas Stupka 2012-03-16 16:38:59 UTC
any known steps how to reproduce?

thanks
Comment 3 Tomas Stupka 2012-03-26 08:21:15 UTC
*** Bug 210044 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Stupka 2012-04-11 13:47:38 UTC
*** Bug 211013 has been marked as a duplicate of this bug. ***
Comment 5 Tomas Stupka 2012-05-10 10:46:15 UTC
*** Bug 210043 has been marked as a duplicate of this bug. ***
Comment 6 Tomas Stupka 2012-05-10 10:47:13 UTC
was able to reproduce when reproducing #212266 - seems to be a side effect of the repository combo box model populated by a wrong type.
fixed in scope of #212266
Comment 7 Marian Mirilovic 2013-01-02 16:59:15 UTC
*** Bug 224348 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo