Bug 209666 - CodeCompletion took 18685 ms.
CodeCompletion took 18685 ms.
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Completion & Templates
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Dusan Balek
issues@editor
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-16 14:56 UTC by David Strupl
Modified: 2012-04-04 14:47 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (150.18 KB, application/nps)
2012-03-16 14:56 UTC, David Strupl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Strupl 2012-03-16 14:56:46 UTC
This bug was originally marked as duplicate of bug 204819, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201203150400)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.4-b02-402, Java(TM) SE Runtime Environment, 1.6.0_29-b11-402-11D50b
OS: Mac OS X

User Comments:
dstrupl: Tried code completion after the IDE was long idle.



Maximum slowness yet reported was 18685 ms, average is 18685
Comment 1 David Strupl 2012-03-16 14:56:49 UTC
Created attachment 116803 [details]
nps snapshot
Comment 2 Dusan Balek 2012-03-30 11:22:37 UTC
Code completion is slow due to extremely slow IO (caused by running HG - as can be seen from the attached snapshot). Closing as WONTFIX.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo