Bug 209598 - IllegalArgumentException: #177688: property editor org.openide.explorer.propertysheet.PropUtils$NoPropertyEditorEditor@461030f for property org.apache.tools.ant.module.AntCustomizer$2[name=properties]
IllegalArgumentException: #177688: property editor org.openide.explorer.prope...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Property Sheet
7.1
All All
: P1 with 3 votes (vote)
: 7.3.1
Assigned To: Stanislav Aubrecht
issues@platform
EXCEPTIONS_REPORT, 73patch2-verified
: 731_HR_FIX
: 230536 231594 232794 238451 242544 (view as bug list)
Depends on:
Blocks: 230559
  Show dependency treegraph
 
Reported: 2012-03-14 19:38 UTC by gregkotsaftis
Modified: 2014-03-21 09:16 UTC (History)
25 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.26 KB, text/plain)
2012-03-14 19:38 UTC, gregkotsaftis
Details
stacktrace (5.18 KB, text/plain)
2012-09-15 22:08 UTC, David Konecny
Details
stacktrace (4.14 KB, text/plain)
2012-12-05 08:58 UTC, lehel
Details
stacktrace (7.12 KB, text/plain)
2012-12-13 13:23 UTC, crazyjavahacking
Details
stacktrace (4.18 KB, text/plain)
2013-01-03 10:38 UTC, jaska_tl
Details
stacktrace (4.15 KB, text/plain)
2013-05-30 12:04 UTC, Jiri Rechtacek
Details
stacktrace (4.15 KB, text/plain)
2013-05-30 12:10 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gregkotsaftis 2012-03-14 19:38:46 UTC
This bug was originally marked as duplicate of bug 177688, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.1.1 (Build 201203012225)
VM: Java HotSpot(TM) 64-Bit Server VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b05
OS: Windows 7

User Comments:
gregkotsaftis: if I modify the netbeans.conf to this:
netbeans_default_options="-J-client -J-Xss2m -J-Xms256m -J-Xmx1024m -J-XX:PermSize=128m -J-XX:MaxPermSize=512m -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true -J-Dsun.zip.disableMemoryMapping=true -J-XX:+UseConcMarkSweepGC -J-XX:+CMSClassUnloadingEnabled -J-XX:+CMSPermGenSweepingEnabled -J-Xverify:none --cp:p c:/libs/jgoodies-common-1.3.0.jar;c:/libs/jgoodies-looks-2.5.0.jar --laf com.jgoodies.looks.plastic.PlasticXPLookAndFeel"

I get this exception always when I try to access Options/Misc window.

GUEST: trying select Options->Miscellaneous

gregkotsaftis: it seems that latest JGoodies looks, breaks the property editor

GUEST: - Fresh Netbeans 7.1 installation
- Selecting menu Tools -> Options -> Miscellaneous




Stacktrace: 
java.lang.IllegalArgumentException: #177688: property editor org.openide.explorer.propertysheet.PropUtils$NoPropertyEditorEditor@461030f for property org.apache.tools.ant.module.AntCustomizer$2[name=properties] does not support a custom editor; valueType=java.util.Properties; PropertyEditorManager says: null; search path is: [sun.beans.editors]; CCL: SystemClassLoader[403 modules]
   at org.openide.explorer.propertysheet.CustomEditorDisplayer.setPropertyEditor(CustomEditorDisplayer.java:150)
   at org.openide.explorer.propertysheet.CustomEditorDisplayer.getPropertyEditor(CustomEditorDisplayer.java:129)
   at org.openide.explorer.propertysheet.CustomEditorDisplayer.getCustomEditor(CustomEditorDisplayer.java:120)
   at org.openide.explorer.propertysheet.CustomEditorDisplayer.getComponent(CustomEditorDisplayer.java:353)
   at org.openide.explorer.propertysheet.PropertyPanel.installDisplayerComponent(PropertyPanel.java:492)
   at org.openide.explorer.propertysheet.PropertyPanel.addNotify(PropertyPanel.java:735)
Comment 1 gregkotsaftis 2012-03-14 19:38:49 UTC
Created attachment 116750 [details]
stacktrace
Comment 2 Jaroslav Tulach 2012-05-15 10:05:08 UTC
I am not sure what is going on. The property editor path is short, it includes only "sun.beans.editors", which is suspicious. Maybe declarative way to register search paths could help.
Comment 3 Jesse Glick 2012-05-16 00:08:14 UTC
Seems like a different kind of cause than #177688, which was a problem with Thread.CCL being wrong.
Comment 4 David Konecny 2012-06-20 02:22:18 UTC
I have an old userdir on which this exception happens always. Using a fresh one makes it goes a way.
Comment 5 David Konecny 2012-09-15 22:08:14 UTC
Created attachment 124404 [details]
stacktrace
Comment 6 Exceptions Reporter 2012-09-15 22:08:20 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=185882
Comment 7 lehel 2012-12-05 08:58:54 UTC
Created attachment 128873 [details]
stacktrace

Trying Netbeans menu: Tools->Options->Miscellaneous/Java tabs
Comment 8 crazyjavahacking 2012-12-13 13:23:09 UTC
Created attachment 129318 [details]
stacktrace

After click on Options/Java
Comment 9 jaska_tl 2013-01-03 10:38:16 UTC
Created attachment 129844 [details]
stacktrace
Comment 10 AlexFalappa 2013-02-25 08:08:59 UTC
I confirm this behaviour.

In my case it happens on a fresh NB7.3 install when choosing the Java tab in the options dialog. After the exception is thrown it is not possible to open the whole options dialog anymore.

Environment:
- Ubuntu 12.10
- Oracle JDK 7u15
- JGoodies Looks 2.5.3 (with jgoodies-common 1.6)

In my environment I find the GTK L&F confusing (the biggest problem is that menus have no borders and do not clearly stand out from the window when opened) while Metal is ugly. The JGoodies Looks L&F was a good compromise but this bug seriously mine the whole IDE functionality.
Comment 11 Jiri Rechtacek 2013-05-30 12:04:22 UTC
Created attachment 135130 [details]
stacktrace

Open Options panel
Comment 12 Marian Mirilovic 2013-05-30 12:10:23 UTC
Created attachment 135131 [details]
stacktrace

Tools | Options - Java
Comment 13 Marian Mirilovic 2013-05-30 12:11:29 UTC
100 % reproducible in 
Product Version: NetBeans IDE 7.3.1 (Build 201305291404)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b13
System: Linux version 3.5.0-31-generic running on amd64; UTF-8; en_US (nb)


open Tools | Options and switch to 'Java" .. it will not even open, beside that this exception rises
Comment 14 Marian Mirilovic 2013-05-30 12:21:38 UTC
reproducible also in 
Product Version: NetBeans IDE 7.3 (Build 201305291404)
Updates: NetBeans IDE is updated to version NetBeans 7.3 Patch 2
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b13
System: Linux version 3.5.0-31-generic running on amd64; UTF-8; en_US (nb)

as well as in original 7.3 :
Product Version: NetBeans IDE 7.3 (Build 201302132200)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b13
System: Linux version 3.5.0-31-generic running on amd64; UTF-8; en_US (nb)
Comment 15 Marian Mirilovic 2013-05-30 12:25:12 UTC
... works in :
Product Version: NetBeans IDE 7.3 (Build 201302132200)
Java: 1.7.0_21; Java HotSpot(TM) 64-Bit Server VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Linux version 3.5.0-31-generic running on amd64; UTF-8; en_US (nb)

So, as it looks like :
- jdk7u25 -> broken
- jdk7u21 -> works

As we are going to bundle NB 7.3.1 with JDK7u25, this is stopper for 7.3.1 as well ;(
Comment 16 Stanislav Aubrecht 2013-05-30 14:07:17 UTC
core-main d0b5529b24bb
Comment 17 mclaborn 2013-05-30 14:10:36 UTC
Can we get a patch for 7.3 ?
Comment 18 Tomas Danek 2013-05-30 14:24:14 UTC
verified in custom trunk build, please backport to 7.3.1 (and by increasing spec version also into 7.3 patch2)
Comment 19 Stanislav Aubrecht 2013-05-30 14:26:42 UTC
backported to release73 branch as ce962b7ce537
Comment 20 Tomas Danek 2013-05-30 14:45:31 UTC
verified in 7.3.1 custom build

Product Version: NetBeans IDE 7.3.1 (Build 20130530-ce962b7ce537)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b13
System: Mac OS X version 10.8.3 running on x86_64; UTF-8; en_US (nb)
User directory: /tmp/731test
Cache directory: /tmp/731test/var/cache

will verify in 7.3 patch2 once catalog is available.
Comment 21 Quality Engineering 2013-05-30 18:17:44 UTC
Integrated into 'releases', will be available in build *201305301707* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/ce962b7ce537
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #209598 - ensure property editors are really registered (backport)
Comment 22 Quality Engineering 2013-05-31 01:21:07 UTC
Integrated into 'main-golden', will be available in build *201305302301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d0b5529b24bb
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #209598 - ensure property editors are really registered
Comment 23 Marian Mirilovic 2013-05-31 06:54:33 UTC
*** Bug 230536 has been marked as a duplicate of this bug. ***
Comment 24 Marian Mirilovic 2013-05-31 06:55:52 UTC
looks like it works in :
Product Version: NetBeans IDE 7.3.1 (Build 201305301707)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b13
System: Linux version 3.5.0-31-generic running on amd64; UTF-8; en_US (nb)

Tomas, please double-check.
Comment 25 Tomas Danek 2013-05-31 12:26:04 UTC
verified in 7.3 + latest patch2 bits from staging.
Comment 26 Marian Mirilovic 2013-06-21 10:28:00 UTC
*** Bug 231594 has been marked as a duplicate of this bug. ***
Comment 27 Stanislav Aubrecht 2013-07-16 12:47:16 UTC
*** Bug 232794 has been marked as a duplicate of this bug. ***
Comment 28 Stanislav Aubrecht 2013-12-10 16:02:33 UTC
*** Bug 238451 has been marked as a duplicate of this bug. ***
Comment 29 Stanislav Aubrecht 2014-03-21 09:16:18 UTC
*** Bug 242544 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo