Bug 209583 - IDE sometimes start with blank components
IDE sometimes start with blank components
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: JDK Problems
7.1.1
PC Mac OS X
: P1 (vote)
: 7.1.1
Assigned To: Antonin Nebuzelsky
issues@platform
jdk_bug_7154505-fixed-7u4-b20
: JDK_1.7, JDK_SPECIFIC, RANDOM, UI
: 221006 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-14 15:53 UTC by Tomas Danek
Modified: 2012-10-29 11:48 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (96.08 KB, image/png)
2012-03-14 15:53 UTC, Tomas Danek
Details
screenshot2 (96.50 KB, image/png)
2012-03-14 16:12 UTC, Tomas Danek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2012-03-14 15:53:30 UTC
Created attachment 116738 [details]
screenshot

Product Version         = NetBeans IDE Dev (Build 201203090400) (#9a710a8e3e80)
  Operating System        = Mac OS X version 10.7.3 running on amd64
  Java; VM; Vendor        = 1.7.0_04-ea; Java HotSpot(TM) 64-Bit Server VM 23.0-b16; Oracle Corporation
  Runtime                 = Java(TM) SE Runtime Environment 1.7.0_04-ea-b15
-----------------------
no exact steps to reproduce, but randomly when starting ide into the same userdir, IDE starts completely blank (see screenshot). To be more specific, everything seems to be ok for ~1second and then all content of window (titles, nodes,...) disappears. Popup is displayed correctly, as well as e.g. text can be copy-pasted.
Comment 1 Stanislav Aubrecht 2012-03-14 15:59:28 UTC
running the IDE under debugger doesn't indicate any problems - correct foreground colors are set, correct fonts being used but invoking Graphics.drawString() does not paint any text.
all other visual artifacts (backgrounds, borders etc) seem to be painting fine, just no text is showing - except for tooltips and and popup menus.
Comment 2 Stanislav Aubrecht 2012-03-14 16:04:58 UTC
btw, the IDE runs by default with the following java switches: 

-Dapple.laf.useScreenMenuBar=true 
-Dapple.awt.graphics.UseQuartz=true 
-Dsun.java2d.noddraw=true 
-Dsun.zip.disableMemoryMapping=true

(not sure if they have any effect on this issue though)
Comment 3 Tomas Danek 2012-03-14 16:12:10 UTC
Created attachment 116741 [details]
screenshot2
Comment 4 Tomas Danek 2012-03-14 16:12:58 UTC
as expected, reproduced also in NB 7.1.1 -> stopper for bundle
Comment 5 Antonin Nebuzelsky 2012-03-16 14:37:19 UTC
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7154505
Comment 6 Marian Mirilovic 2012-03-21 14:08:15 UTC
We need to solve it for 7u4, if not it will end up in our bugcount. In case we will not be able to push on that, I would vote for RELEASE NOTES - it's not enough, but it will inform users about possible workaround.
Comment 7 Marian Mirilovic 2012-06-07 12:42:10 UTC
Tomas, could you please verify this issue ? Thanks in advance.
Comment 8 Tomas Danek 2012-06-08 12:22:03 UTC
verified - haven seen it since then.
Comment 9 Antonin Nebuzelsky 2012-10-29 11:48:04 UTC
*** Bug 221006 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo