Bug 209468 - Source file opens in wrong window panel
Source file opens in wrong window panel
Status: RESOLVED INVALID
Product: platform
Classification: Unclassified
Component: Window System
7.1.1
PC Linux
: P3 with 3 votes (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on: 211836
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 13:51 UTC by nedenom
Modified: 2013-09-25 18:02 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nedenom 2012-03-12 13:51:09 UTC
After performing a search or inspecting call hierarchy, double clicking on a file opens it in the output panel, together with search and call hierarchy results, instead of in the main panel with other source files.
Comment 1 Petr Somol 2012-03-14 10:45:17 UTC
Could not reproduce. Jan, please would you evaluate to reassign to whoever this might belong ?
Comment 2 nedenom 2012-03-17 20:38:09 UTC
Maybe something to do with imported settings from NB 7.0. I deleted my 7.1 profile directory and it seems to behave normally now. I just have to take the time to reconfigure NB all over again.
Comment 3 catweasle 2012-03-18 21:38:23 UTC
I have about the same problem.
If I am positioned in a run tab in the output pane and open up a source file by double clicking in the project browser,
the source file opens up in the tab in the output pane I was positioned in.
I also imported settings of my previous installation when installing 7.1.1.
I'm reopening this, not sure if I'm allowed to do that,
sorry if that's not polite.

jan
Comment 4 allanNB 2012-03-28 16:04:59 UTC
same issue in Netbeans 7.2 beta build 201203120400
Comment 5 Michel Graciano 2012-03-28 16:41:34 UTC
There are a couple of settings for tab at Tools > Options > Miscellaneous > Windows. Maybe 'New document opens next to active document' or something else?
Comment 6 allanNB 2012-03-28 19:45:52 UTC
(In reply to comment #5)
> There are a couple of settings for tab at Tools > Options > Miscellaneous >
> Windows. Maybe 'New document opens next to active document' or something else?


None of these settings affect this bug. I also tested 'New document opens next to active document' to no avail.
Comment 7 adriaaaaaan 2012-03-30 09:23:51 UTC
I also have this issue Its soooo annoying!  I also upgraded from 7.0
Comment 8 Kkloe 2012-04-02 12:43:32 UTC
Same here, started happening after I made an call stack trace(not just that thou).
As I was doing several things it was hard to say what caused it. Tried to somehow reproduce this, no luck

Too fix it I had to do was go:
Window->Reset Windows

Product Version: NetBeans IDE 7.1 (Build 201112071828)
Java: 1.6.0_30; Java HotSpot(TM) Client VM 20.5-b03
System: Windows 7 version 6.1 running on x86; Cp1252; sv_SE (nb)
Comment 9 Jan Becicka 2012-04-23 13:15:06 UTC
this is window system i hope
Comment 10 Stanislav Aubrecht 2012-04-23 14:25:52 UTC
Most likely caused by manually docking Output or Search Results or some other window by splitting the editor area. The Output window is then considered a document window and its docking spot is reserved for document windows - there are scroll left/right and drop down buttons in the upper right corner of that area.
Menu 'Window - Reset Windows' brings back the default state.

If that is not the case then please attach a screen shot and reopen, thanks.
Comment 11 nedenom 2012-04-27 09:36:09 UTC
I messed up the windows again... at least I know there is a Reset Windows command now. Still a nuisance though, to re-arrange to my preferences over again.

That explanation in previous comment is probably correct, but rather complicated and I cannot imagine a user wanting to achieve this on purpose. 

I don't know if this behavior is a side effect of general refactoring, but the way it worked in the previous version was fine, for me at least.
Comment 12 localhorst 2012-09-10 13:03:11 UTC
Resetting windows wokred for me in NB 7.2
Comment 13 localhorst 2012-11-18 20:49:47 UTC
I found a workaround by saving my cuurent configuration using the "Perspective" plugin. Check this post on Stackoverflow: http://stackoverflow.com/questions/12490730/can-i-save-my-window-layout-in-netbeans-7-2
Comment 14 strange_loops 2013-09-25 18:02:04 UTC
I had a similar problem in 7.3. Reset Windows worked as well.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo