Bug 209369 - Inspect Members dialog focus issues
Inspect Members dialog focus issues
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
7.1.1
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
: FOCUS, JDK_1.7
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 10:34 UTC by mco
Modified: 2012-05-02 23:52 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mco 2012-03-09 10:34:00 UTC
Inspect members ui does not get focus when opened. It's opening in the front, but when you start typing everything goes to last focused editor.

I think best would be that "Filter:" field gets focus when opening members UI.
Comment 1 Petr Somol 2012-03-12 12:14:25 UTC
I tried this on 7.1, 7.1.1, and on the daily build with JDK 1.6u29. In all cases it works as expected, i.e, the focus is in Filter: field upon Inspect Members dialog opening. What JDK version do you use ? Can you observe the faulty behavior also on other machines ?
Comment 2 mco 2012-03-12 12:30:47 UTC
I'm using 1.7 from Oracle:

java version "1.7.0_03"
Java(TM) SE Runtime Environment (build 1.7.0_03-b05)
Java HotSpot(TM) 64-Bit Server VM (build 22.1-b02, mixed mode)

I've done small test and switched to 1.6.0_31:

java version "1.6.0_31"
Java(TM) SE Runtime Environment (build 1.6.0_31-b05)
Java HotSpot(TM) Client VM (build 20.6-b01, mixed mode, sharing)

It works fine on 1.6.

Switched back to 1.7 and it fails, so it looks like it's 1.7 specific.
Comment 3 Stanislav Aubrecht 2012-03-28 13:36:00 UTC
can't reproduce in

Product Version: NetBeans IDE Dev (Build 20120326-142a2031e2c0)
Java: 1.7.0_03; Java HotSpot(TM) Client VM 22.1-b02
System: Windows 7 version 6.1 running on x86; Cp1250; en_US (nb)
Comment 4 keil 2012-05-02 23:52:13 UTC
I had the same issue with NB 7.1.1 and JDK 1.7.0_04 on Win XP.

It works fine with NB 7.1.2 and JDK 1.7.0_04 on Win XP.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo