Bug 209327 - ClassCastException: javax.swing.JLabel cannot be cast to javax.swing.JMenuItem
ClassCastException: javax.swing.JLabel cannot be cast to javax.swing.JMenuItem
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
7.2
All All
: P3 (vote)
: 7.2
Assigned To: Stanislav Aubrecht
issues@platform
EXCEPTIONS_REPORT
:
: 209352 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 13:47 UTC by schkovich
Modified: 2012-03-09 15:28 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.72 KB, text/plain)
2012-03-08 13:47 UTC, schkovich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description schkovich 2012-03-08 13:47:45 UTC
Build: NetBeans IDE Dev (Build 201203080400)
VM: Java HotSpot(TM) 64-Bit Server VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Linux

User Comments:
schkovich: Switching between editor tabs (php files)




Stacktrace: 
java.lang.ClassCastException: javax.swing.JLabel cannot be cast to javax.swing.JMenuItem
   at javax.swing.plaf.metal.MetalIconFactory$MenuArrowIcon.paintIcon(MetalIconFactory.java:1886)
   at javax.swing.plaf.basic.BasicLabelUI.paint(BasicLabelUI.java:167)
   at javax.swing.plaf.ComponentUI.update(ComponentUI.java:161)
   at javax.swing.JComponent.paintComponent(JComponent.java:778)
   at javax.swing.JComponent.paint(JComponent.java:1054)
   at javax.swing.JComponent.paintChildren(JComponent.java:887)
Comment 1 schkovich 2012-03-08 13:47:47 UTC
Created attachment 116473 [details]
stacktrace
Comment 2 Stanislav Aubrecht 2012-03-08 13:53:20 UTC
core-main fa7b93653aac
Comment 3 Jesse Glick 2012-03-08 19:58:33 UTC
I was having lots of problems with the popup switcher in 20120308-cb9e08f5027a but with this patch it seems better.
Comment 4 Stanislav Aubrecht 2012-03-08 20:14:42 UTC
(In reply to comment #3)
> I was having lots of problems with the popup switcher in 20120308-cb9e08f5027a
> but with this patch it seems better.

so are there any other problems?
Comment 5 Jesse Glick 2012-03-08 20:32:54 UTC
Not that I have noticed so far. Will file anything separately that I find.
Comment 6 Stanislav Aubrecht 2012-03-09 08:50:33 UTC
*** Bug 209352 has been marked as a duplicate of this bug. ***
Comment 7 Quality Engineering 2012-03-09 11:06:01 UTC
Integrated into 'main-golden', will be available in build *201203090400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/fa7b93653aac
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #209327 - CCE
Comment 8 schkovich 2012-03-09 15:28:57 UTC
Verified using:
Product Version: NetBeans IDE Dev (Build 201203090400)
Java: 1.7.0; Java HotSpot(TM) 64-Bit Server VM 21.0-b17
System: Linux version 3.0.0-16-generic running on amd64; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo