Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 209239 - Prefer unforked javac whenever possible
Prefer unforked javac whenever possible
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Harness
7.2
PC All
: P2 (vote)
: 7.2
Assigned To: Jesse Glick
issues@apisupport
: PERFORMANCE, REGRESSION
Depends on:
Blocks: 208464
  Show dependency treegraph
 
Reported: 2012-03-06 15:14 UTC by J Bachorik
Modified: 2012-03-26 22:40 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J Bachorik 2012-03-06 15:14:01 UTC
Recently I've noticed a significant increase in the netbeans build time
(cca. 10x). It is caused by the 630c26d3ebdb changeset which was
supposed to fix compiling a NBM using JDK7 while NB was running on JDK6 (issue #208464).

I've backed out the changeset and measured the build times. The results
are following -

Current state:
===================
real	50m40.632s
user	69m24.868s
sys	4m0.623s

Changeset backed-out:
=====================
real	8m21.480s
user	7m56.910s
sys	0m57.476s
Comment 1 Petr Cyhelsky 2012-03-21 08:47:10 UTC
Why is this only P2? This is seriously slowing down not only normal work but also some tests...
Comment 2 Petr Cyhelsky 2012-03-21 08:48:25 UTC
This is also affecting windows
Comment 3 Jesse Glick 2012-03-26 22:40:36 UTC
core-main #907121fd4102


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo