Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 209169 - [72cat] SQL files are not identified as owned by a project correctly
[72cat] SQL files are not identified as owned by a project correctly
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
7.1
PC All
: P1 with 3 votes (vote)
: 7.1.2
Assigned To: Jiri Rechtacek
issues@db
71patch2-verified
: REGRESSION
: 208150 208901 210386 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 13:11 UTC by Michel Graciano
Modified: 2012-04-11 11:00 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2012-03-05 13:11:17 UTC
[ BUILD # : 201112071828 ]
[ JDK VERSION : 1.7.1 ]

The SQL files are not identified as owned by a project correctly after a IDE
restart. To reproduce the issue:
1. Create a SQL file for a Java project (it was first identified at a Free Form
project);
2. Open this SQL file;
3. Close and open the IDE again;
Result: The SQL file is no longer identified as owned by the project, so Ctrl +
Shift + 1 doens't work, the IDE tile does not identify the project anymore too
and several another side efects. It is necessary to close the file and reopen
it using the Projects view for example.
Comment 1 Michel Graciano 2012-03-05 13:12:29 UTC
I consider it a P1 because if you make changes at the file, the Save operation is not available. The workaround is to use Save All, but it can cause data loss if the user does not see this.
Comment 2 Michel Graciano 2012-03-05 13:18:36 UTC
Maybe it has the same cause of issue #208901.
Comment 3 matthias42 2012-03-05 21:09:01 UTC
The problem lies in the fact, that after the restart the lookup of the top component is mostly empty. There seems to be a problem in the serialisation. At least the file object needs to be in the lookup to make "select in ..." work. I would next have alook at the sqleditorsupport and the atgributes of the editor itself, they being completely transient seems strange (although possible).
Comment 4 Jiri Rechtacek 2012-03-06 07:28:00 UTC
(In reply to comment #3)
> The problem lies in the fact, that after the restart the lookup of the top
> component is mostly empty. There seems to be a problem in the serialisation. At
> least the file object needs to be in the lookup to make "select in ..." work. I
> would next have alook at the sqleditorsupport and the atgributes of the editor
> itself, they being completely transient seems strange (although possible).

Thanks for hints. I guess it might be related to changes due to issue 200424.
Comment 5 Jiri Rechtacek 2012-03-07 20:34:28 UTC
Reproducible with 7.1 FCS build on machine.

  Product Version         = NetBeans IDE 7.1 (Build 201112071828) (#e649e0c4c10c)
  Operating System        = Linux version 3.0.0-16-generic running on amd64
  Java; VM; Vendor        = 1.6.0_20; Java HotSpot(TM) 64-Bit Server VM 16.3-b01; Sun Microsystems Inc.
  Runtime                 = Java(TM) SE Runtime Environment 1.6.0_20-b02
  Java Home               = /usr/local/share/java/jdk1.6.0_20/jre
  System Locale; Encoding = en_US (nb); UTF-8
Comment 6 Jiri Rechtacek 2012-03-12 18:59:13 UTC
(In reply to comment #2)
> Maybe it has the same cause of issue #208901.

You are right, it seems both problems share a same cause, wrong deserialization of SQL TopComponent.
Comment 7 Michel Graciano 2012-03-12 20:19:06 UTC
I am eager to get the fix asap. This issue is really annoying me :(

If you need anything from here, just let me know.
Comment 8 Jiri Rechtacek 2012-03-13 17:31:09 UTC
Uff. It seems it's fixed now - core-main/rev/03fad8037fc2
Comment 9 Jiri Rechtacek 2012-03-13 17:32:33 UTC
*** Bug 208901 has been marked as a duplicate of this bug. ***
Comment 10 Michel Graciano 2012-03-13 17:36:33 UTC
I will verify it as soon as it hit the main repo. Thanks to mark this as candidate for 7.1.2.
Comment 11 Jiri Rechtacek 2012-03-13 17:41:10 UTC
*** Bug 208150 has been marked as a duplicate of this bug. ***
Comment 12 Quality Engineering 2012-03-17 10:35:42 UTC
Integrated into 'main-golden', will be available in build *201203170400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/03fad8037fc2
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #209169: [72cat] SQL files are not identified as owned by a project correctly
Comment 13 Michel Graciano 2012-03-17 20:26:38 UTC
v. Build 20120317-3ad82e81863d
Comment 14 Marian Mirilovic 2012-03-22 12:26:01 UTC
Jirka, 
please proceed with integration into release71_fixes branch and follow http://wiki.netbeans.org/NetBeansPatchesProcess . Thanks in advance.
Comment 15 Jiri Rechtacek 2012-03-23 10:34:31 UTC
(In reply to comment #14)
> Jirka, 
> please proceed with integration into release71_fixes branch and follow
http://hg.netbeans.org/releases/rev/772d614c5db0
> http://wiki.netbeans.org/NetBeansPatchesProcess . Thanks in advance.
http://hg.netbeans.org/releases/rev/16c533695bec
Comment 16 Quality Engineering 2012-03-25 02:41:21 UTC
Integrated into 'releases', will be available in build *201203242206* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/772d614c5db0
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #209169: [72cat] SQL files are not identified as owned by a project correctly
(transplanted from 03fad8037fc20df60abfe806a87a34ccb9717b18)
Comment 17 matthias42 2012-03-30 20:41:54 UTC
*** Bug 210386 has been marked as a duplicate of this bug. ***
Comment 18 Tomas Danek 2012-04-11 11:00:31 UTC
thanks, works now fine in 7.1.2

Product Version: NetBeans IDE 7.1.2 (Build 201204101705)
Java: 1.7.0_04-ea; Java HotSpot(TM) 64-Bit Server VM 23.0-b20
System: Mac OS X version 10.7.3 running on amd64; US-ASCII; en_US (nb)
User directory: /Users/tomas/.netbeans/7.1.2
Cache directory: /Users/tomas/.netbeans/7.1.2/var/cache


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo